[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#228018: gcc-3.3: [alpha] cc1 Internal error when building fceu-0.97.5

Joe Nahmias writes:
> Package: gcc-3.3
> Version: gcc-3.3_1:3.3.2-4 & 3.3.3-0pre2
> Severity: normal
> Hello,
> I recently uploaded a new version of my package fceu.  When the alpha
> autobuilder (lully) tried to build this it produced the following error:
> gcc  -Wall -g -O2 -Wall -Winline -DOPENGL -DFRAMESKIP -DSTDIOIFACE \
> -DUNIXDSP -DNETWORK -DFPS `sdl-config --cflags` -Izlib \
> -fomit-frame-pointer -DSDL -DUNIX -DPSS_STYLE=1 -DZLIB   -c -o x6502.o \
> x6502.c
> x6502.c: In function `X6502_Run':
> x6502.c:574: warning: inlining failed in call to `X6502_RunNormal'
> x6502.c:693: warning: called from here
> x6502.c:442: warning: inlining failed in call to `X6502_RunDebug'
> x6502.c:695: warning: called from here
> gcc: Internal error: Killed (program cc1)
> Please submit a full bug report.
> The full build log is available at:
> <http://buildd.debian.org/fetch.php?&pkg=fceu&ver=0.97.5-2&arch=alpha&stamp=1072363095&file=log&as=raw>
> Also, vorlon tried to build the package with gcc 3.3.3-0pre2 and had a
> similar result which caused cc1 to eat up 658MB of virtual memory before
> he killed it.
> Let me know if I can be of any further assistance!

- the preprocessed source

- did it work with g++-3.2?

- does it work with gcc-snapshot?

Thanks, Matthias

Reply to: