[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#197001: g77 no longer compiles using static libraries


A Diumenge 06 Juliol 2003 09:18, Matthias Klose va escriure:
> - Please could you provide a test program which shows the behaviour?

This is just an example program:

        program prova

        call feline

      subroutine feline

>From bib.f I create a library libbib.a:

kadath:/home/kadath/guerrero>g77 -c bib.f
kadath:/home/kadath/guerrero>ar r libbib.a bib.o

And then I try to compile:

kadath:/home/kadath/guerrero>g77 -L. -lbib prova.f
/tmp/cc8W8jGw.o: In function `MAIN__':
/tmp/cc8W8jGw.o(.text+0x7): undefined reference to `feline_'
collect2: ld returned 1 exit status

I ran into the problem in several computers (3 Athlon XP, all of them running 
woody) with the libxspec.a library of the XSPEC program. The bug appeared in 
all of them. I reinstalled XSPEC several times before I found that g77 was 
failing with all static libraries and not just libxspec.a . The Athlons are 
all of them new installations.

I've tried to compile the above test in a PIII and a PII (both upgraded to 
woody from potato) and I get the same error (and none of them has xspec 

> - Are you able to reproduce the behaviour with the current g77 in
>   testing/unstable?

I really don't know, I don't have any computer running testing/unstable. If 
you think it may help I can get a 486 and install testing in it...

Thanks for your message, and if you need more information don't hesitate to 

Josep Guerrero

Reply to: