[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#178867: libstdc++5: shlibs depends >=1:3.2.1-1 - compiling against 3.2.2 breaks running against 3.2.1

Package: libstdc++5
Version: 1:3.2.2-0pre6
Severity: important

libstdc++5.shlib declares a dependency of >=3.2.1-1. However, an application
built against 3.2.2 doesn't appear to run if 3.2.1 is installed, giving

/usr/lib/libstdc++.so.5: version `GLIBCPP_3.2.2' not found

-- System Information
Debian Release: testing/unstable
Kernel Version: Linux vavatch 2.4.20-xfs #1 Sat Jan 25 03:01:49 GMT 2003 i686 unknown unknown GNU/Linux

Versions of the packages libstdc++5 depends on:
ii  gcc-3.2-base   3.2.2-0pre6    The GNU Compiler Collection (base package)
ii  libc6          2.3.1-10       GNU C Library: Shared libraries and Timezone
ii  libgcc1        3.2.2-0pre6    GCC support library

Reply to: