[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Freedombox-discuss] Unattended updates not running

Hi all,

I enabled unattended updates in plinth, but it isn't doing the updates. 
I've run apt-get update then apt-get dist-upgrade before going to bed to
see if anything needs to be upgraded.  Then I answer "no" about doing
the upgrades.  The following morning I run apt-get dist-upgrade to see
if anything has been done.  For three days in a row now, no unattended
upgrades have been done.

I've tried disabling the upgrades in plinth, rebooting, reenabling
upgrades, and rebooting again.  It didn't make any difference. 

I can manually trigger upgrades in plinth, but enabling automatic
upgrades doesn't work.

There are next to no logs in /var/log/unattended-upgrades despite my
having installed this back in May:

------------- begin file listing ---------------------
root at freebx:/var/log/unattended-upgrades# ls -l
total 20
-rw-r----- 1 root adm     0 Sep 11 06:25 unattended-upgrades-dpkg.log
-rw-r----- 1 root adm   508 Sep 10 10:00
-rw-r----- 1 root adm  1161 Jun  6 10:23
-rw-r--r-- 1 root root  708 Sep 10 10:00 unattended-upgrades.log
-rw-r--r-- 1 root root  281 Sep  9 22:58 unattended-upgrades.log.1.gz
-rw-r--r-- 1 root root  390 Jun  6 10:23 unattended-upgrades.log.2.gz
-rw-r--r-- 1 root root    0 Dec 10  2015
root at freebx:/var/log/unattended-upgrades# 
--------------- end file listing -------------------

The man page is pretty minimalist.  Can anyone suggest what to do to
debug this?


  znoteer at hailmail.net

http://www.fastmail.com - Accessible with your email software
                          or over the web

Reply to: