[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Deprecating Python 2 support of python-fonttools



Hi,

As being described in the upstream issue tracker [1], they are going to
deprecate the Python 2 support for fonttools.

There are several packages relying on python-fonttools (of Python 2
version), or old fonttools package which was Python 2 library:

  * fonts-hack
  * fonts-noto-color-emoji
  * fonts-roboto-slab
  * fonts-smc-anjalioldlipi
  * fonts-smc-chilanka
  * fonts-smc-dyuthi
  * fonts-smc-karumbi
  * fonts-smc-keraleeyam
  * fonts-smc-meera
  * fonts-smc-rachana
  * fonts-smc-raghumalayalamsans
  * nototools

This was listed from the following command, then handpicked by checking
if that's depending on the older fonttools and python-fonttools package,
rather than python3-fonttools or fonttools as binary:

  grep-dctrl -FBuild-Depends fonttools -sPackage /var/lib/apt/lists/*Sources

Best regards,
Yao Wei

[1]: https://github.com/fonttools/fonttools/issues/765

Attachment: signature.asc
Description: PGP signature


Reply to: