[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rv: swfdec-mozilla is no longer part of the Debian version you are using

Hash: SHA1

On 08/27/2010 08:44 PM, Miriam Ruiz wrote:
> I'm forwarding this to the Flash Packaging Group:

I was having a look at svn commits when... hey! An email to the
flash-group! ;)
Since we reminded debian-flash ml existence, a dozen of subscribers are
not subscribers anymore:


Are the remaining ones no longer valid addresses? Maybe.
BTW, yes, I'd prefer using debian-flash ml too in order to separate
discussions from bugs/commits.

> --- El vie, 27/8/10, Santiago Garcia Mantinan <manty@debian.org>
> escribió:
>> De: Santiago Garcia Mantinan <manty@debian.org> Asunto:
>> swfdec-mozilla is no longer part of the Debian version you are
>> using Para: 593202@bugs.debian.org CC: gnash@packages.debian.org 
>> Fecha: viernes, 27 de agosto, 2010 17:51 Hi!
>> As swfdec is no longer being actively developped anymore we have
>> decided to stop distributing it, lenny is the last release that
>> will have it, squeeze won't.
>> The sugestion would be to install mozilla-plugin-gnash and remove
>> all swfdec related packages (aptitude should be telling you that
>> they are no longer part of Debian).
>> I'm Ccing the gnash maintainers because it seems like a good idea
>> to have squeeze automatically replace the old and currently
>> useless version of swfdec's mozilla plugin with gnash's
>> alternative. How does this idea look like to you?
>> If you like it... how should we implement this? can you take care
>> of it from the gnash src?

I would proceed in this way (just committed, ready to be reverted :))
Adding a transitional dummy packages:

Package: swfdec-mozilla
Priority: extra
Architecture: all
Depends: mozilla-plugin-gnash (= ${binary:Version})
Description: dummy package for transition to mozilla-plugin-gnash

and some relationships to gnash-common:

Package: gnash-common
Provides: libswfdec-0.6-90, libswfdec-0.8-0
Replaces: libswfdec-0.6-90, libswfdec-0.8-0
Conflicts: libswfdec-0.6-90, libswfdec-0.8-0

This replaces swfdec-mozilla and swfdec libraries when
swfdec-mozilla users upgrade and it works fine because gnash
version number (0.8.8) is greater than swfdec ones.

And what about swfdec-gnome on a system without swfdec-mozilla? Never
mind? I'd like to replace it with gnash package but its major version is
2 and gnash would only prevail with epoch+1.
At the moment, I've added the swfdec-gnome replacement that however
can be only triggered manually or by mozilla-plugin-gnash upgrade, if
Any ideas about doing it automatically?

Package: gnash
Provides: swfdec-gnome
Replaces: swfdec-gnome
Conflicts: swfdec-gnome


Version: GnuPG v1.4.10 (GNU/Linux)


Reply to: