[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Potato, DHCP and IPMASQ

I've got a K6-200 box that has been running Potato since January that I
recently tried to switch to an ipmasqing machine.  When I first
installed I was using DHCP on the Netgear (tulip) 100mbit (eth1), but I
switched over to the 10mbit 3Com 3c900 (eth0).  Both cards worked just
fine.  To setup the ipmasqing, I grabbed the 2.2.16 kernel source, the
.config from a working firewall here at work and reconfigured for the
appropriate hardware.  Everything worked just fine after installing the
new kernel.  I'm using the dhcpcd .deb (latest version) which works just
fine.  The problem is that when I install the ipmasq .deb, I can't get a
network connection again.  Pinging www.yahoo.com returns 

ping: unknown host www.yahoo.com

and pinging the local dhcp server returns 

ping: sendto: Operation not permitted
ping: wrote 64 chars, ret=-1
...100% packet loss

If I remove the ipmasq .deb and restart the box, dhcp works again.  I've
tried wiping and reinstalling dhcpcd and ipmasq several times, but I
can't get past this error.

Any suggestions?
Matthew H. Ray
Programmer, Coral Technologies, Inc.

Reply to: