[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted postgresql-common 141 (source all)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 10 Apr 2013 16:25:06 +0200
Source: postgresql-common
Binary: postgresql-common postgresql-client-common postgresql-server-dev-all postgresql postgresql-client postgresql-doc postgresql-contrib
Architecture: source all
Version: 141
Distribution: experimental
Urgency: low
Maintainer: Debian PostgreSQL Maintainers <pkg-postgresql-public@lists.alioth.debian.org>
Changed-By: Christoph Berg <myon@debian.org>
Description: 
 postgresql - object-relational SQL database (supported version)
 postgresql-client - front-end programs for PostgreSQL (supported version)
 postgresql-client-common - manager for multiple PostgreSQL client versions
 postgresql-common - PostgreSQL database-cluster manager
 postgresql-contrib - additional facilities for PostgreSQL (supported version)
 postgresql-doc - documentation for the PostgreSQL database management system
 postgresql-server-dev-all - extension build tool for multiple PostgreSQL versions
Closes: 682938 689996 700271 701602
Changes: 
 postgresql-common (141) experimental; urgency=low
 .
   [ Christoph Berg ]
   * debian/maintscripts-functions: Fix configure_client_version to call
     _link_manpages correctly, spotted by Kris Shannon. (Closes: #701602)
   * debian/postgresql-common.sysctl: Note that the file is Linux-specifc and
     do some rewording of the comments.
   * debian/supported-versions:
     + Deprecate 8.3 for pgdg builds.
     + Handle missing os-release and lsb_release gracefully, just print a
       warning. (Affects squeeze systems, Introduced by the fix for #697182).
   * pg_buildext: Deprecate <srcdir> parameter. The docs do not mention it
     anymore, but the script will still accept it.
   * pg_createcluster, pg_upgradecluster: For 9.2 and higher, use the new
     ssl_ca_file option instead of creating a root.crt symlink in the data
     directory. (Related to the fix for #680162 below.)
   * pg_createcluster: If /etc/postgresql-common/root.crl is present, symlink
     it (<= 9.1), or set ssl_crl_file (>= 9.2).
   * pg_ctlcluster: Create (first) unix_socket_directory if missing.
   * pg_ctlcluster: Document start.conf by pointing at pg_createcluster(8).
   * pg_lsclusters: Make output column widths dynamically adjust to contents;
     shorten "Version" in header to "Ver".
   * pg_upgradecluster: Get cluster encoding before shutting down the cluster
     so we don't need to restart it in pg_upgrade mode; temporarily start the
     cluster if needed.
   * postgresql-client-common: For apt.postgresql.org builds (with "pgdg" in
     the version number), depend on pgdg-keyring.
   * Add a "apt.postgresql.org.sh" script to add that archive to sources.list.
 .
   [ Martin Pitt ]
   * debian/backport-ppa: Stop building raring packages. The PPA is declared
     deprecated now, moving to apt.postgresql.org.
   * pg_createcluster: Drop "Moving configuration file.." message as it's not
     all that interesting and we are going to add more status output.
   * pg_createcluster: Print configuration and data directory on separate
     lines, and also show the current locale that the cluster will use.
     (Closes: #700271)
   * pg_updatedicts: Cleanup tsearch data files which do not have a
     corresponding hunspell or myspell dictionary installed any more.
     (Closes: #689996)
   * Adjust upgrade tests according to the changed pg_lscluster formatting.
 .
   [ Peter Eisentraut ]
   * Add support for pg_upgrade: (Closes: #682938)
     - pg_upgradecluster: Add options to select pg_upgrade instead of
       dump/restore, and call pg_upgrade when selected.
     - t/040_upgrade.t: Test all upgrade methods.
Checksums-Sha1: 
 c3ff5837ac4b97ca919f569a844303c50b52db55 2151 postgresql-common_141.dsc
 130fb5d0a65308ebbfee8f544db87889a08b3856 157076 postgresql-common_141.tar.gz
 25d5246d298d71c61546d253887785d581e06a53 50076 postgresql-server-dev-all_141_all.deb
 f11ef1a6bbad71e77b6fd4b059ca8d35dac46535 45476 postgresql_9.1+141_all.deb
 ae53ba4ea3b55f5db97b57f2fffcc957efff572c 45502 postgresql-client_9.1+141_all.deb
 8dbc41f10cab67e883037b9adc52aebfb5287f67 45486 postgresql-doc_9.1+141_all.deb
 cfcdfcb415b8151bc0bc069786f46775464dfb7a 45506 postgresql-contrib_9.1+141_all.deb
 48a126055815c5d6fa74557084478eeef86c87d4 150770 postgresql-common_141_all.deb
 ce78043e8ceb6c723ce16ca90f892c9cd35fa284 66226 postgresql-client-common_141_all.deb
Checksums-Sha256: 
 0788c47ef0fe0a732cd2862b2369838eef71e1d32e7258327aace312baf42a42 2151 postgresql-common_141.dsc
 43a2c7bb94b726e305052bf6b4504efce5a7b6eef68ef87d70b82caad7bff62f 157076 postgresql-common_141.tar.gz
 08e770d9d2d82dd504474781187cfc9e01a727b959131ba057227fafe19f690f 50076 postgresql-server-dev-all_141_all.deb
 ff0950870c3b94185052c11435d85dde66405d025f5fde15d145bb35c6a48aeb 45476 postgresql_9.1+141_all.deb
 1e43bee751057c20f3597b42a380d723aae2b0442420d0d9dd12779ee8fa5069 45502 postgresql-client_9.1+141_all.deb
 92d2c74bd1f3cd9e7548ffd262b57e2ce508b219f46d72752512f609f2872594 45486 postgresql-doc_9.1+141_all.deb
 5074af1d28708c512092fff8d66afda716be539c4e9a8c518892ad43be061436 45506 postgresql-contrib_9.1+141_all.deb
 47aa7cae15c17a2bcb7a8df2bb9c1e1debc36d5dcb2ee1838aee0bbe031c3fb9 150770 postgresql-common_141_all.deb
 d70033712457ddd80052e2c966bb6ce4c2a52f1a4286a60908fa913a811e731e 66226 postgresql-client-common_141_all.deb
Files: 
 661d6b2e9405edc1ef1d0aed256800ff 2151 database optional postgresql-common_141.dsc
 5bf09bdf7aadb5aea941582ce5a93f8a 157076 database optional postgresql-common_141.tar.gz
 a3ebff82a762b845b45b618092ab2f34 50076 database optional postgresql-server-dev-all_141_all.deb
 3d2b35302f5d28b3ddf8c904fa266951 45476 database optional postgresql_9.1+141_all.deb
 c204e81eff3dad343b4edf2f7314919d 45502 database optional postgresql-client_9.1+141_all.deb
 ebc1b71c9b8884575d42f0338f66e4b7 45486 doc optional postgresql-doc_9.1+141_all.deb
 0357e3bc0f0e0457bcdca4cdd82f55eb 45506 database optional postgresql-contrib_9.1+141_all.deb
 163c173a634468ec31146d60ffb4bb02 150770 database optional postgresql-common_141_all.deb
 cd42bd148a6d1f17043e3ab2c9851ef1 66226 database optional postgresql-client-common_141_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRZYQoAAoJEExaa6sS0qeugNMP/1kZJQnwMDFlaGdEyStZbTur
uIrTDSN+za2ijd5szibcAuUBgp61osgxrumbwvNcE0LEUENn9eJjubybwkQCCRqu
U5MH8pLENSFM8ThMbrfVW7AnVyJ7LhLyCW8YXtBS8zFAAcYJ5uSVcDYDJmCUehMi
IXMn+q4R5E7iTSGZUaxOzpkSm37+F0+6zo5Lac/9zVE5DKyGWhag2k44XJptqVdg
A2FOps/Mrz3FsLh2Wi3lHUJXW2VJsXp3Y2JHi0Ru8sG50aTvX8vbROKqn+N8yOun
de6AK6U9f1Bhh6iemr7Qykg57U9gVzj4l9BEZnar7eObnD9HWwhfztT6se0VdN4Z
5WFLMF04ChuCnsaNFRMyY8JV28LWC74QYMBcUI/SLcJOpa89EnP4Ih4aIDz9gHC8
t/uYkmHpEoRGzGMyflYrhlXsaSTqkv6MTJhniO8EoiDw1fFyWWhyIPj05Lpe9nHM
fjA7/nOMDLJEGylvCSY/3QlbJ63g6zxTJRG2PovcQ2McI4fw+T7aqsU6IhozbyTF
fgIVyhNX9Ws2Oc9slkqoQNNYIwgEHp4+OfP4TSxrsoS0kGWAG8ClV7bYzynAl6GM
PCXLq2nW23F0B8iyo5ueTz2WinLqieEeEsGNthtLKZ9LPAzTeEpwU69th8fQJou+
AqMisMkax8G/ZXoOj+Ft
=mNCJ
-----END PGP SIGNATURE-----


Reply to: