[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Queries about netboot deployment of Debian Squeeze

This affects Lenny too but mainly squeeze right now.

The dhcp timeout setting is not respected, I have tried it in many
variations found online and many different values but none have
worked. The progress bar never waits more than 20 seconds and I have
to retry 1-3 times every deployment. I get paid to press enter, up,
up, enter but I think it's quite embarrassing to not have it fixed.

d-i netcfg/dhcp_timeout string 120
d-i netcfg/dhcp_timeout=120
And as a desperate attempt even d-i netcfg/dhcp_options select Retry
network autoconfiguration but I couldn't get that to work either.

Has anyone managed to solve this issue? I notice many preseed manuals
mention this as a common problem, slow DHCPd that is, but I have yet
to solve it.

The other question is about late_command and in-target, can I somehow
chroot myself into /target and finish the installation with a fully
working Debian system? I've tried doing this by running a bash script
using chroot, and also in-target prefixed to the command but chroot
didn't work at all and in-target gave me errors. So since I can't get
it right I would love to see someone elses take on this because right
now we create an rc.local script that we clobber just before rebooting
one final time. This is something I would like to get done during the
install process instead.


Med vänliga hälsningar / With kind regards

Stefan Midjich

Reply to: