[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[PATCH] new file: TODO

The Josh Schauer posting to the emdebian mailinglist
saved as 'TODO' in the git repository.

In git is better then a mailinglist archive ...
 TODO |   86 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 files changed, 86 insertions(+), 0 deletions(-)
 create mode 100644 TODO

diff --git a/TODO b/TODO
new file mode 100644
index 0000000..fea6a67
--- /dev/null
+++ b/TODO
@@ -0,0 +1,86 @@
+Hi all,
+just a short status update of the things that are currently required to
+make polystrap - building debian rootfs without superuser permissions -
+fully work out-of-the-box.
+1. fakechroot
+fakechroot is still having a bug where the root path gets prefixed twice
+in certain situations (when doing mknod and when using certain
+architectures like armhf). Unfortunately the maintainer seems to be MIA
+but I'm in touch with the debian-mia team about that and a NMU might
+I reported and proposed a patch here:
+2. qemu-user-static elf interpreter prefix
+Currently, one has to fill the /etc/qemu-binfmt/* directories before
+executing any dynamically compiled foreign executable with
+fakeroot/fakechroot because there is no way to pass the -L parameter to
+qemu-user-static to specify the just extracted rootfs directory as the
+elf interpreter prefix path. Being able to do so by making it evaluate
+an environment variable instead, would be a huge improvement because it
+would make it possible to avoid changing the content of
+/etc/qemu-binfmt/* directories every time
+ * one changes between debian architectures that use the same qemu
+   emulation (eg. arm, armel and armhf all use qemu-arm)
+ * one changes between different debian suites
+ * shared library versions are outdated
+I reported and proposed a patch here:
+3. fakeroot/fakechroot multiarch
+To execute code in a foreign rootfs with fakeroot/fakechroot,
+libfakechroot.so and libfakeroot-sysv.so need to be present in the
+appropriate /usr/lib/<arch-triplet>/ directory. Currently I copy those
+into it manually with dpkg -x. This problem should be solved by
+multiarch, right? Is it already possible? What is missing?
+4. building for mips/mipsel
+This issue currently fails due to some bugs related to wrong syscall
+handling in qemu-mips. The effect is explained in these mails to the
+qemu-devel list:
+A patch that supposedly (did not yet test) solves the issue was posted
+just today:
+Once it is committed, building for mips/mipsel should work again.
+5. tzdata
+There is currently a bug in tzdata that is triggered when using
+debconf-set-selections before configuring the package. It can be avoided
+by not setting any tzdata values in debconfseed.txt. I did not find the
+time to look into why exactly that happens or to prepare a patch but
+given how quickly other recent similar issues were solved this will
+probably also be fixed soon.
+I reported and explained the issue here:
+I hope I didnt forget anything.
+cheers, josch

Reply to: