[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Hi Wookey,

I'm on a quest to set up a proper build system for the Flukso server. The current server is based on a stock Debian Lenny Xen image with quite a number of patches and compilations from source. I would like to be able to provision a Xen DomU, excluding kernel, as a Flukso server from scratch.

I started off with debootstrap, but since this only results in a bare-bones Debian with no apt support, I dug a bit deeper and found Emdebian's multistrap. This looks like a very promising provisioning tool. Ubuntu 10.04 ships with a really old version, so I downloaded and extracted the 2.1.14 deb package. I can now build a Squeeze filesystem in a flat file. However, the script's output reports an error:

Errors were encountered while processing:

Bash has a dependency towards the base-files package:

dpkg: dependency problems prevent configuration of bash:
 bash depends on base-files (>= 2.1.12); however:
  Package base-files is not configured yet.
dpkg: error processing bash (--configure):
 dependency problems - leaving unconfigured

So it boils down to base-files not installing properly;

Setting up base-files (6.0squeeze1) ...
chown: invalid user: `root:root'
dpkg: error processing base-files (--configure):
 subprocess installed post-installation script returned error exit status 1

Egrepping for root:root in the base-files package results in this output:

icarus75@cirrus:~/flukso/fstrap/base-files-6.0squeeze1$ egrep -rn 'root:root' . ./debian/changelog:89: * Changed default /usr/src to be root:root and 755. Closes: #573701. ./debian/changelog:337: * Made /home to be 755 and root:root by default, since nobody finds
./debian/postinst.in:81:  chown root:root /var/lib/dpkg
./debian/postinst.in:86:  chown root:root /var/lib/dpkg/status
./debian/postinst.in:92:  chown root:root /usr/share/info/dir
./debian/rules:62:	chown -R root:root debian/tmp

It looks like the chown command(s) in postinst.in are the culprit. I'm running multistrap under sudo, tried to run it directly under root as well. But I always get the same error. I noticed your handle in the multistrap release log. Have you encountered something similar before? Would you have any suggestions on how to solve or bypass this issue?

All help is highly appreciated!

Best regards,

Bart Van Der Meerssche
Nieuwstraat 104
B-3150 Wespelaar

tel: ++32/479/28 14 48
skype/twitter: flukso
email: bart.vandermeerssche@flukso.net
web: www.flukso.net

Reply to: