[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HOWTO example for ReadOnly Rootfs using multistrap

Am 18.01.2011 23:45, schrieb Hector Oron:

Surely something to look at it. Thanks.
Hi Hector, many thanks for the feedback.

I have found some bugs which could be filed against the BTS
(excerpt of TODO:
- fsck.ubifs dummy package similar to fsck.nfs (fsck.ubifs is not

 From UBI documentation:
UBIFS is tolerant of unclean reboots and power-cuts. It does not need
stuff like fsck.ext2.
Yes. I know. That is what I found, too. But anyway the debian standard setup tries to check every filesystem (but nfs). Since there is no fsck.ubifs this produces alienate messages on startup. Debian ignores fsck for NFS - so it should ignore ubifs, too. The fsck.nfs thing was solved with a dummy package. To keep the pattern, a similar dummy package for fsck.ubifs should be created.
This bug ticket patches some skript:
Anyway, I prefere to keep the pattern and create a dummy package similar to fsck.nfs.

- noauth must be true even if Emdebian archive keyring installed on host

I thought that was already fixed.
I did not try the newest version from sid. My host system is a debian squeeze amd64 without "sid-backports".

- mksquashfs 4.0 from Squeeze did not work for me on my arm target, 4.1 from
Sid does)

In which way failed for you?
The mksquashfs (4.0) command itself does not show any error. But when I try to mount the generated image with mount -o loop,ro my.sqfs /mnt/sqtest it breaks with some weird trace messages viewable via dmesg. I tried the same mksquashfs command (4.1) and it could be mounted via mount -o loop,ro without problems. (I tried to put the sq-image on several media - usbstick, 2,5"usbdrive and internal nand flash - that was NOT the reason - the 4.0 image was NOT mountable from anywhere [armelbox#mksquashfs /var /.var.sqfs.new -noI -noD -noF])

Any comments on RO solution with aufs-overlay?

Thanks again for the feedback.


Reply to: