[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem setting up for arm cross environment from emdebian.org packages.

I've just installed a bunch of cross tools, and ran into a problem attempting to set up 'g++'. When I attempt to do so, the following output is emitted by 'dpkg' (transcribed manually from the development

libstdc++6-4.3-dev-armel-cross: Depends: gcc-4.3-arm-linux-gnueabi-base (= 4.3.3-5) but 4.3.2-1.1 is to be installed

(and a few more like that...)

But when I perform an 'apt-get install' on the above 'Depends' item, the apt-get responds with 'the package is the latest'. Further, when I search emdebian.org for the libstd++6 package, the 'gcc-4.3-arm-linux-gnueabi-base that is referenced
in the dependency list, points to an amd64 package.

My development system is not an AMD, nor is it even 64, what does this mean in terms of where is the correct packages?

My sources.list has the following: (taken from the website...)

deb http://www.emdebian.org/debian/ lenny main

John Clark.

Reply to: