[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cross compile for kernel 2.4



On Sat, 18 Apr 2009 16:10:13 -0300
Ernesto <forosylistas@ernet.com.ar> wrote:

> Hi,
> 
> I need to compile some program for running in a mipsel target, which has linux 
> 2.4.

2.4 could be a problem if the version of glibc is also as old as a 2.4
kernel.

> I wonder if it can be done using the debian-embedded tools, from a linux 2.6 
> system.

It depends more on the version of libc6 and other dependencies - if
your program compiles natively under a Debian 2.6 & glibc 2.9
environment, you could use the mipsel toolchains for testing or
unstable. For glibc 2.7 you will need the toolchains for stable.
There is no emdebian-tools package in old stable (etch) (glibc 2.3).

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.linux.codehelp.co.uk/
http://e-mail.is-not-s.ms/

Attachment: pgppo4hsG0y0O.pgp
Description: PGP signature


Reply to: