[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel cross-compile problem with embdebian's toolchain

New error messages with the new kernel:
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

prefetch abort
pc : [<9ea5507c>]    lr : [<a1714e30>]
sp : a16bfcbc  ip : 00000005  fp : 00000002
r10: 00000000  r9 : a16e04e0  r8 : a16bffdc
r7 : a1721bf8  r6 : a16c028e  r5 : a0000154  r4 : a000015a
r3 : a0008000  r2 : a0000100  r1 : 00000196  r0 : 00000000
Flags: Nzcv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...

Maybe some trash in the memory?

A recompile the old kernel source with this toolchain and it works again... (I did that about 1 week ago, and now I want to be sure about it work)


Zachár Balázs wrote:
> Hector Oron wrote:
>> Hi,
>>   Could you try armel toolchain, which is arm-linux-gnueabi?
> I tried the gnueabi-gcc for build a static hello world, and it isn't work on my board (to the best of my memory the error was: illegal instruction or something this ) and the hello world with compiled
> gnu-gcc worked properly...
> I compile the orig kernel source with this toolchain and its worked too...
> another strange thing is the size... Because:
> New kernel emdebian toolch (gzipped): 4,3 MB
> New kernel old toolchain(gzipped): 1,4 MB
> Old kernel new toolch(gzipped):	1,33MB
> Old kernel Old toolch(gzipped):	1,33MB
> And I compile the same sources with the same parameters...
> regards

Reply to: