[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#514249: Implementing the patch



On Sun, 15 Feb 2009 11:03:23 +0000
Neil Williams <codehelp@debian.org> wrote:

> Now that Lenny has been released, I can't see any reason to retain
> -dcv1 packages in Squeeze, especially as dpkg-cross is destined to be
> part of dpkg by then.
> 
> I've implemented the patch above and I'm going to upload 2.4.0 to
> Debian unstable with -dcv1 provision removed.

One amendment to the patch - in order for newly built -cross packages
to not only be installable but also not to break reverse dependencies
that have not yet been updated to remove the -dcv1 dependency, the
patch has been tweaked to retain the Provides: without adding the
dependency:

Index: dpkg-cross
===================================================================
RCS file: /cvsroot/dpkg-cross/dpkg-cross/dpkg-cross,v
retrieving revision 1.67
diff -p -u -b -B -r1.67 dpkg-cross
--- dpkg-cross	15 Feb 2009 11:04:18 -0000	1.67
+++ dpkg-cross	15 Feb 2009 11:19:31 -0000
@@ -1009,8 +1009,13 @@ sub sub_build {
 	}
 
 	# Rewrite dependency fields
+	# Make 'provides' field to exist always to all $package-$arch-dcv1
+	# but create no dependencies on dcv1 - see #514249
+	$control{"provides"} = "" unless defined $control{"provides"};
 	for $field qw(depends conflicts provides replaces) {
 		next if not defined $control{$field};
+		print CONTROL ucfirst($field) . ": ".$control{"package"} ."-$arch-dcv1\n"
+			if ($field eq "provides");
 		my $rewritten = rewrite_dependencies($control{$field});
 		if (length($rewritten) > 0) {
 			# Capitalize first letter of field name

 Package: libqof1-arm-cross
 Version: 0.7.5-1
 Section: devel
 Priority: extra
 Architecture: all
 Maintainer: Debian QOF packaging team <pkg-qof-maintainers@lists.alioth.debian.org>
 Source: libqof1
 Depends: libc6-arm-cross (>= 2.7-1), libgda3-3-arm-cross, libglib2.0-0-arm-cross (>= 2.12.0)
 Conflicts: pilot-qof-arm-cross (<< 0.1.1-2)
 Provides: libqof1-arm-dcv1

This allows libqof-dev to remain installed with dependencies met, until
it is updated itself.

$ apt-cache show libqof-dev-arm-cross
Package: libqof-dev-arm-cross
Status: install ok installed
Priority: extra
Section: devel
Maintainer: Debian QOF packaging team <pkg-qof-maintainers@lists.alioth.debian.org>
Architecture: all
Source: libqof-dev
Version: 0.7.5-1
Provides: libqof-dev-arm-dcv1
Depends: libgda3-dev-arm-cross, libgda3-dev-arm-dcv1, libqof1-arm-cross (= 0.7.5-1), libqof1-arm-dcv1

The Provides itself can be removed in Squeeze+1.

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpJvoOctFHc8.pgp
Description: PGP signature


Reply to: