[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Status of gpe on emdebian crush

I'm trying to run gpe on emdebian crush on a ARM iMX21 based board.
After a few minor problems due to busybox differences in some script
files (should I file bug reports for these?) I have startx working.

However none of the gpe stuff works. Virtually all gpe applications
(gpe-clock, gpe-edit,...) have trouble loading PNGs :
GPE-ERROR: Couldn't recognize the image file format for file

I appear to have the loader files installed:
# pwd
# ls loaders
libpixbufloader-ani.so   libpixbufloader-ico.so
libpixbufloader-png.so   libpixbufloader-tga.so
libpixbufloader-bmp.so   libpixbufloader-jpeg.so
libpixbufloader-pnm.so   libpixbufloader-tiff.so
libpixbufloader-gif.so   libpixbufloader-pcx.so
libpixbufloader-ras.so   libpixbufloader-wbmp.so

My normal next step would be to use strace,ltrace,objdump and ldd to
try and figure out what is going on but the first three don't appear
to be in emdebian and ldd is a shell script that requires bash  (i've
tried dash but to no avail).

Are there any good reasons for not including these tools? Should I try
to build emdebian packages locally for them?

Also some gpe applications (eg gpe-edit) have pango problems:

(gpe-edit:2238): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
You should create this file by running:
 pango-querymodules > '/etc/pango/pango.modules'

(gpe-edit:2238): Pango-WARNING **: failed to find shape engine, expect
ugly output. engine-type='PangoRenderFc', script='latin'

Indeed I have no pango.modules file (just an empty /etc/pango directory)
I don't have pango-query modules and the libpango1.0-dev package which
normally provides it is not installable due to an unresolved
dependency on pkg-config:

# apt-get install libpango1.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libpango1.0-dev: Depends: libglib2.0-dev (>= 2.12.0) but it is not
going to be installed
                   Depends: libfreetype6-dev (>= 2.1.3) but it is not
going to be installed
                   Depends: libx11-dev but it is not going to be installed
                   Depends: libxrender-dev but it is not going to be installed
                   Depends: pkg-config but it is not installable
                   Depends: libxft-dev but it is not going to be installed
                   Depends: libfontconfig1-dev (>= 2.1.91) but it is
not going to be installed
                   Depends: libcairo2-dev (>= 1.2.6) but it is not
going to be installed
E: Broken packages

Thanks for any suggestions


Reply to: