[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: failure installing emdebian grip powerpc on ibook

So I ran the following (based one of Jelle de Jong's emails).

# debootstrap --arch powerpc unstable /target http://buildd.emdebian.org/grip/

and got the same error messsges.
I: Configuring initscrips...
I: Configuring sysvinit...
W: Failure while configuring required packages.

I ran "chroot /target" and "dpkg --configure -a" and got the following.

Setting up grip-config (0.0.4em1) ...
/var/lib/dpkg/info/grip-config.postinst: line 6: apt-key: command not found
dpkg: error processing grip-config (--configure):
 subprocess post-installation script returned error exit status 127
Setting up gcc-4.3-base (4.3.2-1em1) ...
ln: acessig `/usr/share/doc/gcc-4.3-base/.copyright': No such file or directory
dpkg: error processing gcc-4.3-base (--configure):
 subprocess post-installation script returned error eit status 1
Errors were encountered while processing:

Within the chroot i used dpkg to install grip-config and apt (along with all the dependencies). This seem to go without a hitch. dpkg -l gives a list of packages all with -em1 :) However, trying to install the base system from the installer still fails because of the signatures. Guess that's because it is not using the chroot (/target).

I skipped the Install Base System in the installer and seleted Confiugre Package Manager. It tried to install the base system first, but pressing escape seemed to skip that . /target/etc/apt/sources.list is now updated with the emdebian statements. Installer now seems to be stuck on the screen "Select and install software". Been stuck on "Please wait ..." for 10 minutes now :(

Think I might have to reboot now as installer is now not responding.

Brendan Simon wrote:
But there is /usr/share/debootstrap/scripts/ directory with contents:
etch    etch-m68k    gutsy    hardy    intrepid    lenny    sid

Copied sid to unstable and it got further :) Now fails because it can't authenticate :(

debootstrap: Can't check signature: public key not found

Now lost on how to get the emdebian keys into the installer. I don't have gpg (only gpgv). There is no apt-key or apt-secure. Only apt-install, apt-setup and apt-setup-verify

How do I get emdebian keys into the installer so that installation can continue without errors ?

Brendan Simon wrote:
Found this via google.


There does not seem to be a /usr/lib/debootstrap/scripts directory (viewed using VT2) on.
The debootstrap directory exists but not the scripts subdirectory.

I'm looking in / but maybe I should be looking in /target ??? Hmmm, /target exists but /target/usr does not. Guess the installer hasn't got that far yet.

Brendan Simon wrote:
Neil Williams wrote:
On Wed, 17 Dec 2008 17:06:33 +0100
Jelle de Jong <jelledejong@powercraft.nl> wrote:

I tried some testing today for debian grip.

I booted up my system with a live usb stick system

My preferred test would have been a debian-installer USB stick, boot
into the normal Debian installer and enter the Grip mirror instead of
one of the listed Debian mirrors.

Debian Live isn't ready for Grip at this time.

and set my archives to debian sid and emdebian

deb http://buildd.emdebian.org/grip/ unstable main
deb http://ftp.nl.debian.org/debian/ unstable main

That's a mistake - grip is an entirely self-contained repository and
does not need debian, at least not until after installation when you
might want extra packages not yet available in Grip.

Specifying a debian mirror will cause debootstrap to select packages
that you don't want (like man-db and groff).

I have an old PowerPC (G3) iBook and tried to install grip on it via the debian-installer (business card iso) but failed.

 * select "http" (#)
 * select "enter information manually".
 * specify "buildd.emdebian.org"
 * specify "/grip"
 * specify "unstable"

 # NOTE: specify "http" only showed up on a retry.
   My first few attempts failed as I specified "/grip/" and "grip".
   It seems picky and you have to specify "/grip" exactly.

* partitioned - using LVM with one group and two volumes (swap & root).

Failed installing base system - Log from VT4 follows.
 debootstrap: E: NOSCRIPT
 debootstrap: EA: /usr/share/debootstrap/scripts/unstable
 debootstrap: EF: No such script: %s

Any ideas where to go from here ???

Reply to: