[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: emsecondstage on at91rm9200 board


thanks for the reply.

On a similar note, how can I set the root password? I found #484700,
which mentions a problem with chpasswd
>From my chroot-ed emdebian rootfs I tried the following:

a) cat passwd.txt | chpasswd
where passwd.txt contains my root password in the form
"root:mypassword". I then tried to reboot and login (through nfs-root)
to the filesystem but my new password didn't seem to take effect.

b) I also tried to run passwd but I get:

/ # passwd
passwd: pam_start() failed, error 26

Is there a default emdebian root password? Can I set the root password
from the host machine e.g. during emsandbox ?

any suggestions are welcome.
thanks again,

- Vasilis

On Sat, Nov 22, 2008 at 1:38 AM, Neil Williams <codehelp@debian.org> wrote:
> On Fri, 21 Nov 2008 22:40:49 -0600
> "Vasilis Liaskovitis" <vliaskov@gmail.com> wrote:
>> Configuring cdebconf
>> Unknown localized field:
>> Choices-fr: slushdot, spoiledmeat, leenoox dawt cawm, leenox tuday,
>> Description-fr: This is my demo info in French (yeah, right)
>> Cannot open template file /var/lib/cdebconf/templates.dat: Invalid
>> argument
>> the file templates.dat is there, but it's empty. Have I missed
>> something or done something wrong?
> No, you haven't done anything wrong. See #451130.
> Congratulations!
> What you need now is to copy the root filesystem to the device, along
> with the kernel and modules, decompress and run ./emsecondstage on the
> device.
> --
> Neil Williams <codehelp@debian.org>
> --
> To UNSUBSCRIBE, email to debian-embedded-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: