[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem about install cross compile tool on lenny



On Fri, 4 May 2007 09:25:45 +0200
Raphael Hertzog <hertzog@debian.org> wrote:

> On Fri, 04 May 2007, Neil Williams wrote:
> > You should have gcc-4.1-arm-linux-gnu NOT arm-cross.
> >
> > http://www.emdebian.org/toolchains/search.php?package=gcc-4.1-arm-linux-gnu&arch=i386&distro=unstable
> > http://www.emdebian.org/toolchains/search.php?package=gcc-4.1-arm-linux-gnu-base&distro=unstable&arch=i386
>
> Those packages in the unstable branch match the gcc version in lenny/etch.
> They do not match the gcc version in unstable.
>
> Would it be possible to copy them in the etch/lenny branch ?

They already exist in the Emdebian testing repository:

http://www.emdebian.org/toolchains/search.php?package=gcc-4.1-arm-linux-gnu&arch=i386&distro=testing
http://www.emdebian.org/toolchains/search.php?package=gcc-4.1-arm-linux-gnu-base&distro=testing&arch=i386

This is because the Emdebian toolchain in unstable cannot upgrade to
the current version of gcc or glibc in Debian unstable because Debian
unstable is RC buggy in both cases.

> Currently all branches are broken. If we do that, at least etch/lenny
> would work.

AFAICT lenny already works. (I'm still running the Lenny toolchains in
unstable - see other email).

emdebian-tools does not exist in Etch.

There is no way to fix unstable until Debian has fixed versions of
glibc and gcc-4.1 that build successfully on Emdebian target
architectures like arm.

--


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpV2dNz9h8OS.pgp
Description: PGP signature


Reply to: