[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Building cross gcc-3.4 for amd64 on i386

   Hello all,

I am in front of a similar issue but trying to do it in the newbie way: I switched to Etch for my host and tried to install the packages from emdebian instead of building them. I could install powerpc-linux-gnu-gcc-4.1 but this one finds errors when compiling kernel 2.6.8. Therefore I tried to install powerpc-linux-gnu-gcc-3.4 but it has a dependency problem: requires gcc-3.4-base version 3.4.6-4, while this version has been replaced by 3.4.6-5. The problem I am facing is that Emdebian has synchronized with Etch and this one has still not been frozen. I'm considering the option of just bypassing the dependency issue.

   Best regards.

Hector Oron a écrit :
Hello Pawel,

 You are missing some libraries, like libgcc1. Check

 I have not had time to go over amd64 -> i386 but it is known that
does not build properly, check #395022 (it applies to gcc-4.1, but it
happens on gcc-3.4 also).

 So i you are able to build it, please report it.

 Good luck !

2007/1/17, Pawel Tecza <ptecza@uw.edu.pl>:
Hello again! :)

I'm trying to build cross gcc-3.4 for amd64 on my i386 box
with Debian 'sarge', using information I've found in the shell
script [1] by Nikita Youshchenko.

I've just built and installed following packages:

* binutils-x86-64-linux:            2.15-6
* dpkg-cross:                       1.32
* libc6-amd64-cross:                2.3.2.ds1-22sarge4
* libc6-dev-amd64-cross:            2.3.2.ds1-22sarge4
* libdb1-compat-amd64-cross:        2.1.3-7
* linux-kernel-headers-amd64-cross: 2.5.999-test7-bk-17

Unfortunately, a building of cross gcc-3.4 fails:

$ wget http://security.debian.org/debian-security/pool/updates/main/g/gcc-3.4/gcc-3.4_3.4.3-13sarge1.dsc $ wget http://security.debian.org/debian-security/pool/updates/main/g/gcc-3.4/gcc-3.4_3.4.3.orig.tar.gz $ wget http://security.debian.org/debian-security/pool/updates/main/g/gcc-3.4/gcc-3.4_3.4.3-13sarge1.diff.gz

$ wget http://zigzag.lvk.cs.msu.su/~nikita/debian/cross-patches/gcc-3.4-cross-3.4.3-13.patch.20050708

$ dpkg-source -x gcc-3.4*dsc
$ cd gcc-3.4-3.4.3/
$ patch -p0 < ../gcc-3.4-cross-3.4.3-13.patch.20050708

$ GCC_TARGET=amd64 fakeroot debian/rules binary
/usr/x86_64-linux/bin/ld: skipping incompatible /usr/x86_64-linux/lib/libc.so when searching for -lc /usr/x86_64-linux/bin/ld: skipping incompatible /usr/x86_64-linux/lib/libc.a when searching for -lc /usr/x86_64-linux/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux/3.4.4/../../../../x86_64-linux/lib/libc.so when searching for -lc /usr/x86_64-linux/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux/3.4.4/../.
./../../x86_64-linux/lib/libc.a when searching for -lc
/usr/x86_64-linux/bin/ld: skipping incompatible /usr/x86_64-linux/bin/../lib/libc.so when searching for -lc /usr/x86_64-linux/bin/ld: skipping incompatible /usr/x86_64-linux/bin/../lib/libc.a when searching for -lc
/usr/x86_64-linux/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
make[4]: *** [32/libgcc_s_32.so] Error 1
make[4]: Leaving directory `/home/ptecza/Debian/cross/amd64/gcc-3.4-3.4.3/build/gcc'
make[3]: *** [stmp-multilib] Error 2
make[3]: Leaving directory `/home/ptecza/Debian/cross/amd64/gcc-3.4-3.4.3/build/gcc'
make[2]: *** [all-gcc] Error 2
make[2]: Leaving directory `/home/ptecza/Debian/cross/amd64/gcc-3.4-3.4.3/build'
s=`cat status`; rm -f status; test $s -eq 0
make[1]: *** [stamps/05-build-stamp] Error 1
make[1]: Leaving directory `/home/ptecza/Debian/cross/amd64/gcc-3.4-3.4.3'
make: *** [stamps/05-build-stamp] Error 2

Did I miss something?  Could you please give me any hint?

My best regards,

Pawel Tecza

[1] http://buildd.emdebian.org/repos/tools/compbuild/trunk/compbuildscript

To UNSUBSCRIBE, email to debian-embedded-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: