[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#978104: marked as done (dh-make-elpa: Can't locate object method "home_dir" via package "DhMakeELPA::Config" at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 387.)

Your message dated Sun, 03 Jan 2021 05:49:00 +0000
with message-id <E1kvwGC-0006Dq-50@fasolo.debian.org>
and subject line Bug#978104: fixed in dh-make-elpa 0.19.1
has caused the Debian Bug report #978104,
regarding dh-make-elpa: Can't locate object method "home_dir" via package "DhMakeELPA::Config" at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 387.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

978104: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=978104
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: dh-make-elpa
Version: 0.19
Severity: grave
Tags: patch


when trying to use dh-make-elpa, it aborts for me as follows:

$ dh-make-elpa --pkg-emacsen --version="1+24+gc830b9d"
I: couldn't generate d/docs: not fully implemented
Can't locate object method "home_dir" via package "DhMakeELPA::Config" at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 387.

Exit code is 25.

I suspect that the actually trying to be packaged mode doesn't make a
difference here, but for the sake of completeness: This happened during
trying to package https://github.com/mickeynp/ligature.el.

Since home_dir seems to be a hash key and not a method, I tried to
enclose it in curly brackets. Then it bails out on the next word. In the
end I also had to fix these errors, too, to get it running until the

Can't locate object method "data_dir" via package "DhMakeELPA::Config" at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 387.
Can't locate object method "verbose" via package "DhMakeELPA::Config" at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 392.

My first try was to convert the function calls to hash accesses. Which
seems to have worked.

So I looked through perl5320delta(1) to see if there was a change in
Perl which could trigger this, but found none on a first glance.

Then I checked the dh-make-perl code to see if the same code is in
there, too. And it is. So I checked which code is different and in the
end I figured that (probably with the separation from dh-make-perl) too
much code has been removed from dh-make-elpa compared to
dh-make-perl. More precisely, re-adding these options (!) fixed it as in
the call to __PACKAGE__->mk_accessors accessors are generated from the
configured options. Here's the patch:

--- /usr/share/perl5/DhMakeELPA/Config.pm.BACKUP	2020-06-25 20:22:12.000000000 +0200
+++ /usr/share/perl5/DhMakeELPA/Config.pm	2020-12-26 03:56:47.075818430 +0100
@@ -16,9 +16,12 @@
 my @OPTIONS = (
+    'data-dir=s',
+    'home-dir=s',
+    'verbose!',

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (600, 'testing'), (500, 'unstable-debug'), (500, 'buildd-unstable'), (110, 'experimental'), (1, 'experimental-debug'), (1, 'buildd-experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.9.0-4-amd64 (SMP w/4 CPU threads)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

Versions of packages dh-make-elpa depends on:
ii  dh-elpa                 2.0.6
ii  libarray-utils-perl     0.5-1
ii  libdebian-source-perl   0.113
ii  libfile-find-rule-perl  0.34-1
ii  libfile-grep-perl       0.02-1
ii  libgit-repository-perl  1.324-1
ii  libtrycatch-perl        1.003002-2+b7
ii  perl                    5.32.0-6

Versions of packages dh-make-elpa recommends:
ii  devscripts  2.20.5

dh-make-elpa suggests no packages.

-- no debconf information

-- debsums errors found:
debsums: changed file /usr/share/perl5/DhMakeELPA/Command/Packaging.pm (from dh-make-elpa package)

--- End Message ---
--- Begin Message ---
Source: dh-make-elpa
Source-Version: 0.19.1
Done: Lev Lamberov <dogsleg@debian.org>

We believe that the bug you reported is fixed in the latest version of
dh-make-elpa, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 978104@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Lev Lamberov <dogsleg@debian.org> (supplier of updated dh-make-elpa package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA512

Format: 1.8
Date: Sun, 03 Jan 2021 10:20:07 +0500
Source: dh-make-elpa
Architecture: source
Version: 0.19.1
Distribution: unstable
Urgency: medium
Maintainer: Debian Emacsen team <debian-emacsen@lists.debian.org>
Changed-By: Lev Lamberov <dogsleg@debian.org>
Closes: 978104
 dh-make-elpa (0.19.1) unstable; urgency=medium
   * Set up proper accessors
   * Fix missing accessors calls (Closes: #978104)
     Thanks to Axel Beckert
   * Bump copyright years
   * Bump Standards-Version in skeleton package to 4.5.1
   * d/control: Declare Standards-Version 4.5.1 (no changes needed)
 65d3bd3ff3226fe81278e0186134132a1ea3d82d 1621 dh-make-elpa_0.19.1.dsc
 a861e03795ec66fad7a6e22e484d11e45a153daa 14568 dh-make-elpa_0.19.1.tar.xz
 583e0ded49ab7042fdf169541a2d9ef43db53a15 5559 dh-make-elpa_0.19.1_amd64.buildinfo
 e3a4231af23920e0aadd45c9a0b902f7d3a2975ed16e851c28dbfa882ac54e46 1621 dh-make-elpa_0.19.1.dsc
 d9a81cf7aaaa6c9318bfd2085268d8cd8c2e5f816cc7a0a4b3ba7e873878752b 14568 dh-make-elpa_0.19.1.tar.xz
 dbd6fb9eadafab2ad5e79b5fc83927535da05d341f105f35d99a8d685f01f767 5559 dh-make-elpa_0.19.1_amd64.buildinfo
 a952a7a9bd91e5319f6a41285bb2f71a 1621 devel optional dh-make-elpa_0.19.1.dsc
 b89a9a71a9c37819338aae39aa0812c9 14568 devel optional dh-make-elpa_0.19.1.tar.xz
 b1998e1454f060fa221d9d2d193fc1f6 5559 devel optional dh-make-elpa_0.19.1_amd64.buildinfo



--- End Message ---

Reply to: