[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#822724: marked as done (efitools: FTBFS on i386: efibind.h: No such file or directory)

Your message dated Tue, 24 May 2022 18:52:54 +0100
with message-id <20220524175254.GA9728@tack.einval.com>
and subject line Re: Bug#822724: Bug#822725: Bug#822724: efitools: FTBFS on i386: efibind.h: No such file or directory
has caused the Debian Bug report #822724,
regarding efitools: FTBFS on i386: efibind.h: No such file or directory
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

822724: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822724
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Source: efitools
Version: 1.4.2-2
Severity: important
Justification: fails to build from source

Thanks for fixing efitools's Build-Depends setting!  Automated builds
now get further, but still fail on i386, with

  In file included from simple_file.c:7:0:
  /usr/include/efi/efi.h:35:21: fatal error: efibind.h: No such file or irectory

(kfreebsd-amd64 builds also still fail, but with a different error
I'll report separately.)

The i386 version of this header turns out to be in
/usr/include/efi/ia32, not /usr/include/efi/i686.  I see no sign of a
config script that would report this location, so I suppose efitools
will need to hardcode the mapping.

I also noticed two further complications that will affect linking on
i386: the crt0 file is likewise named crt0-efi-ia32.o, and 32-bit
gnu-efi libraries are in /usr/lib32, which isn't in the default search

Could you please take a look?


--- End Message ---
--- Begin Message ---
On Fri, Jan 25, 2019 at 04:20:39PM +0000, Luca Boccassi wrote:
>The latest upload from December builds fine on i386, amd64, armhf and
>arm64, and as far as I can see it's building the EFI binaries with the
>right LD scripts from gnu-efi, eg: elf_aarch64_efi.lds,
>So I think we can close this one too?

Agreed, let's close this now!

Steve McIntyre, Cambridge, UK.                                steve@einval.com
  Getting a SCSI chain working is perfectly simple if you remember that there
  must be exactly three terminations: one on one end of the cable, one on the
  far end, and the goat, terminated over the SCSI chain with a silver-handled
  knife whilst burning *black* candles. --- Anthony DeBoer

--- End Message ---

Reply to: