[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#921760: marked as done (shim-signed: FTBFS (shimx64.efi.signed build/shimx64.efi.signed differ))

Your message dated Tue, 23 Apr 2019 20:14:51 +0100
with message-id <20190423191446.GA14823@tack.einval.com>
and subject line Re: Bug#921760: shim-signed: FTBFS (shimx64.efi.signed build/shimx64.efi.signed differ)
has caused the Debian Bug report #921760,
regarding shim-signed: FTBFS (shimx64.efi.signed build/shimx64.efi.signed differ)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

921760: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=921760
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: src:shim-signed
Version: 1.28+nmu1
Severity: serious
Tags: ftbfs

Dear maintainer:

I tried to build this package in buster but it failed:

 debian/rules build-arch
dh build-arch
   dh_update_autotools_config -a
   dh_auto_configure -a
   dh_auto_build -a
	make -j1
make[1]: Entering directory '/<<BUILDDIR>>/shim-signed-1.28+nmu1'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/<<BUILDDIR>>/shim-signed-1.28+nmu1'
   dh_auto_test -a
	make -j1 check
make[1]: Entering directory '/<<BUILDDIR>>/shim-signed-1.28+nmu1'
mkdir -p build
# Verifying that the image is signed with the correct key.
sbverify --cert MicCorUEFCA2011_2011-06-27.crt shimx64.efi.signed
warning: data remaining[1044456 vs 1169528]: gaps between PE/COFF sections?
Signature verification OK
# Verifying that we have the correct binary.
sbattach --detach build/detached-sig shimx64.efi.signed 
warning: data remaining[1044456 vs 1169528]: gaps between PE/COFF sections?
cp /usr/lib/shim/shimx64.efi build/shimx64.efi.signed
sbattach --attach build/detached-sig build/shimx64.efi.signed
warning: data remaining[1035776 vs 1160847]: gaps between PE/COFF sections?
warning: data remaining[1035776 vs 1160848]: gaps between PE/COFF sections?
Signing Unsigned original image
cmp shimx64.efi.signed build/shimx64.efi.signed
shimx64.efi.signed build/shimx64.efi.signed differ: char 217, line 2
make[1]: *** [Makefile:11: check] Error 1
make[1]: Leaving directory '/<<BUILDDIR>>/shim-signed-1.28+nmu1'
dh_auto_test: make -j1 check returned exit code 2
make: *** [debian/rules:7: build-arch] Error 2
dpkg-buildpackage: error: debian/rules build-arch subprocess returned exit status 2

(The above is just how the build ends and not necessarily the most relevant part)

The build was made in my autobuilder with "dpkg-buildpackage -B"
and it also fails here:


where you can get a full build log if you need it.

If this is really a bug in one of the build-depends, please use reassign and affects,
so that this is still visible in the BTS web page for this package.


--- End Message ---
--- Begin Message ---
On Sat, Mar 09, 2019 at 01:17:59PM +0000, Steve McIntyre wrote:


>I've just uploaded a new shim which is reproducible, so that should
>*hopefully* cause this bug to be fixed before buster release if we get
>the new version signed in time.
>For now, I've asked a friendly local release team person to tag this
>so we don't get removed before then.

In fact, the cause was different - a bug in sbsigntool (specifically
in sbattach). I've fixed that and the problem is solved. Closing this
bug now.

Steve McIntyre, Cambridge, UK.                                steve@einval.com
Into the distance, a ribbon of black
Stretched to the point of no turning back

--- End Message ---

Reply to: