[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#886942: Further information

Further information in two parts, my own experience and a separate bug report.

Part 1.
My PC is a new Intel NUC7i5BNH with both an SSD and HDD. Debian 9 Stretch is installed on both drives, two bootable copies. The EFI timeout pre-configured by Intel was 1 second.

It is clear from web pages and on-line forums that others have successfully used efibootmgr -t. I wondered if it would work with another Distro. I made a live USB of current releases;

Fedora Workstation V27 (efibootmgr version 15)
Ubuntu Desktop 16.04 (efibootmgr version 0.12)

I had the same failure of efibootmgr with both.

I then wondered if the problem only affected current releases so tried an old release;
Ubuntu Desktop 14.04 (efibootmgr version 0.5.4)

With Ubuntu 14.04, efibootmgr -t worked. Things then got stranger.

After re-booting into Debian from my SSD efibootmgr -t still worked. I tried again when booted into Debian from HDD, efibootmgr again still worked.

Did Ubuntu 14.04 change something in the NUC's firmware that allows Debian to now work?

efibootmgr continued to work until I set the timeout back to 1 second, after which the original fault recurred. I then had to reboot from Ubuntu 14.04 and set the timeout to something other than 1 second to recover functionality in Debian.

Part 2.
I found another bug report that describes the same symptoms as I experience but logged against efivar. See;


In Conclusion.
Reproducing the fault may require a combination of firmware/EFI state and OS utility versions.

Reply to: