[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

UEFI netboot and bootnetx64.efi


So i've had a setup working for a number of years where I can netboot
ipxe, then (via a boot menu) chain load pxelinux.0 directly from a
debian webserver and get presented with a debian installer.

This got a little funky with Jessie initially, something was broken so
I simply loaded the netboot kernel and initrd, which also worked well
enough for my purposes.

I now have to install a machine using EFI, but am failing miserably at
working out what's supposed to happen.

I can use my existing setup, install via it, but then my machine fails
to boot as no efi related things are setup. Which is kinda expected
from prior (limited) EFI experience.

So I had a hunt around and notice that bootnetx64.efi exists in the
netboot archive. But I can't find any information about it in any

I tried chain loading it from my ipxe setup just like pxelinux.0, but
that doesn't seem to work.

I tried booting it directly instead of ipxe and that doesn't seem to

I tried a bunch of other things that led to errors.

In the instances where it doesn't error, the problem I has is that I
just see nothing on the console. So i've no idea what it's doing or
expecting to happen. I looked at my tftp server logs and it doesn't
seem to be trying to download any further files.

So what exactly is bootnetx86.efi and how am I supposed to netboot it
in some way that I can install Debian Jessie on my UEFI machine?



Reply to: