[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Squid not listening on IPv6 fe80:: link-local address

Hi Petter, hi Mike,

[Petter Reinholdsen]
My guess is that you need to specify the network interface using the %
[Mike Gabriel]
nope, link-local IPv6 addresses are always related to a specific interface. This is btw. not at all Linux related, IMHO. (Or is it?)

The challenge is that fe80:: is always the link-local prefix, for all link-local networks/interfaces on the same host. So, sending packets to a link-local address always requires the outgoing network interface to be specified with the packet send request.

I wasn't aware of that but it makes sense. it worked when I tried to suffix the address with %eth0 and I was able to connect to squid from a workstation.


inett GmbH
Ihr IT Systemhaus in  Saarbrücken

Marco Gabriel

t: 0681-410993-0
e: mgabriel@inett.de

Technische Fragen:
Support E-Mail: support@inett.de
Support Hotline: 0681-410993-42

inett GmbH | Geschäftsführung: Marco Gabriel | Amtsgericht Saarbrücken HRB 16588

Reply to: