[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1003560: debian-edu-config: stop modifying /etc/apt/apt.conf



Package: debian-edu-config
Severity: important
Version: 2.12.15

The update-proxy-from-wpad script modifies /etc/apt/apt.conf. This is suboptimal because /etc/apt/apt.conf overrides all other settings in /etc/apt/apt.conf.d/**.

When combining Debian Edu with FAI, it might be useful to let FAI override the http_proxy variables (e.g. we use squid-deb-proxy with FAI). So, it would be good to let update-proxy-from-wpad not tweak /etc/apt/apt.conf, but /etc/apt/apt.conf.d/03debian-edu-proxy instead.

FAI provides the /etc/apt/apt.conf.d/02proxy file which IMHO should superceded debian-edu-config's configuration.

This bug is relevant for people who use debian-edu-fai (not yet uploaded, but soon) with Debian Edu 11 or later.

As debian-edu-fai is already in use with Debian Edu 11, it would be cool to provide a fix for this also as a stable-pu.

Mike
--

DAS-NETZWERKTEAM
c\o Technik- und Ökologiezentrum Eckernförde
Mike Gabriel, Marienthaler Str. 17, 24340 Eckernförde
mobile: +49 (1520) 1976 148
landline: +49 (4351) 850 8940

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

Attachment: pgp29ogkPoesr.pgp
Description: Digitale PGP-Signatur


Reply to: