[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#720396: debian-edu-config: debian-edu-config/tools/gosa-create buggy with set -e

Thank you for your bug report.

[Moritz Molle]
> /usr/share/debian-edu-config/tools/gosa-create
> begins with
> set -e
> which means, that it cancels execution after one command which returns
> false.
> further down the script there are the commands
> nscd -i passwd
> and
> nscd -i group
> which, as i tried them, returned false (don't know why, but to be
> robust, the script should expect that).

I see it too.  When I test with strace, this seem to happen because
nscd isn't running.  When I start nscd with 'service nscd restart', it
return 0.

No idea why nscd wasn't running.

> so gosa-create doesn't get to
> create the kerberos-principal of the user which in turn prohibits the
> user to login via ssh.
> also the
> chown $user:$user $homedir
> wont be executed.
> i fixed that by augmenting both the
> nscd -i ...
> lines with "|| true":
> nscd -i passwd || true
> nscd -i group || true
> then it worked.

Look like the correct fix, as there is no need to invalidate the nscd
caches if nscd isn't running, and thus that error should be ignore it.
We will include it, probably in beta2.  (beta1 is already wrapped up
and very close to being released.

Happy hacking
Petter Reinholdtsen

Reply to: