[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#632464: diskless machine probably not added in GOsa

On 03. juli 2011 09:25, Andreas B. Mundt wrote:
> Hi Marius,
> On Sat, Jul 02, 2011 at 11:06:20PM +0200, Marius Kotsbak wrote:
>> On 02. juli 2011 15:43, Andreas B. Mundt wrote:
>>> usually this happens when the home directory cannot be mounted.
>>> 	Did you add the diskless machine in GOa and run ldap2bind after that?
>> You mean ldap2netgroup?
> No, ldap2bind is correct.  It's not in the search path of an ordinary
> user: /usr/sbin/ldap2bind.

Okay, found it.

>>> Whenever I tested that (and added the machine correctly to LDAP), 
>>> things worked fine here.
>> Nope, the documentation is still lacking such details for GOsa. I tried
>> though to add the machine under administration->Systems->Net device.
> I don't have time this month to work on that documentation.

That is okay. As soon as we get reproducable instruction on how to get
this working, anybody should be able to do that. We should not close
this bug report until it is in place (or another replaces it).
>> IP:
>> Base: /Students
>> MAC: the mac I found using dhcp leases
>> Enable dhcp & Enable DNS.
> I never tested with Bases other than /, so if it doesn't work with
> /Students, try /.


>> Are there more options that needs to be changed from default?
> You need to add the machine to the workstation-hosts netgroup (in the
> NIS Netgroups-tab or in Administration->NIS Netgroups).

Ah, I did not see them since they are at Base=/ and by default only
Base=/Students were visible.

But after doing that, it actually works :)

The crucial points to add to the documentation are then:

(* diskless workstations must be added to ldap. And a howto add all
hosts in a network? And how to find the MAC address using the CD).
* Adding the host to the netgroup workstatin-hosts (note about Base=/)
* /usr/sbin/ldap2bind (sudo ...)


Reply to: