[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Is LWAT completely broken in Squeeze?

I've tried to get Lwat limping along in Squeeze, but it seem to be
completely broken.  Did anyone get it working?  I tried to edit
admin.ini to remove the 'none' entries, but that was not enough.

The error I see is a complete failure to log in.  I can enter username
and password, but trying to log in just lead me to the same login
screen. :(

I notice that our lenny-test have version 0.18~beta-3 while squeeze
have version 0.17-4.1.  The beta versions of 0.18 were never uploaded
to Debian, and thus our Squeeze version is lacking everything added
since 0.17:

  lwat (0.18~beta-3) unstable; urgency=low

    * Make sambaGroupMapping when adding a group
    * Disable validation of hostname, IP etc when not updating DNS or DHCP
      to restore old behaviour

   -- John S. Skogtvedt <jss@bzz.no>  Sun, 20 Dec 2009 17:50:07 +0100

  lwat (0.18~beta-2) unstable; urgency=low

    * Added php-net-ipv4 to Depends
    * Added debconf handling of DHCP and DNS settings

   -- John S. Skogtvedt <jss@bzz.no>  Thu, 24 May 2009 15:51:50 +0200

Lwat seem to be dead upstream, unless I am looking at the wrong
location.  If that really is the case, I believe we should drop it
from our Squeeze version and actively look for a replacement.

The two obvious alternatives are Gosa where Andreas have made a draft
implementation in our squeeze-test version of debian-edu-config (but
the working gosa packages are missing in Squeeze), and Cipux, which is
the tool used by our German fork.

Neiter seem to have the simplicity of LWAT, but perhaps they can be
adjusted to provide a simple GUI for the non-skilled admin, and a more
complex GUI for the skilled admin?

CC to the upstream developers and the debian uploader, to make sure
everyone is aware of the state.

Happy hacking,
Petter Reinholdtsen

Reply to: