[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Diskless in Lenny test.

> Petter Reinholdtsen Sent: Tuesday, December 16, 2008 12:33 PM
> Subject: Re: future of debian-edu
> [Valerio Pachera]
> > I wish the diskless workstation to be working fine on lenny.
> > I had several problems with etch.
> > I'm still wondering if they are planned on lenny release (in other 
> > words I wonder if the script ltsp-make-client has been 
> adapted/tested 
> > for lenny).
> I worked on it last developer gathering, and hope it now is 
> working as it should in the Lenny test version.  Did not test 
> it after the last few changes, though.
> I hope we can get it working well enough to enable it by 
> default in Lenny.
> Happy hacking,
> --
> Petter Reinholdtsen

I tried running ltsp-make-client in Lenny (debian-edu-config 1.424~svn55515
on Debian GNU/Linux edu 4.0alpha "Lenny" - Unofficial i386 CD Binary-1
1)	It couldn't execute 'chroot $target aptitude update' as aptitude was
not installed (in the chroot), it's possible to use apt-get. (I did to
install aptitude then ran it again). 
2)	It stopped again after doing 'chroot $target aptitude update' as it
didn't have the public key for the skolelinux repo.
3)	It dropped out once more without any warning at the same point
because it couldn't read the local repo. on CD. (The CD was not in drive).
4)	It hanged after running cfengin with "tail: +: invalid number of
lines", apparently during DHCP modification. Once hitting ^-C it ended

Seems it requires a little more hacking.

Reply to: