[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Tjener kommuniziert nicht mit 10/8 auf eth0 bei statischer IP-Konfiguration



Hi ! :) 

Wir versuchen gerade in der Schule eine Loesung mit Skolelinux 
aufzusetzen. Ein Computer soll sowohl Hauptserver als auch LTSP-Server
fuer die Thinclients sein. Die Neuinstallation des Hauptservers 
funktionierte soweit, jedoch kommuniziert tjener nicht auf eth0 mit 
dem angeschlossenems 10/8 Netz. Ich habe mal in /etc/network/interfaces
die statische adresskonfiguration auskommentiert, da mir die per 
$ifconfig -i eth0 ausgegebenen Konfigurationen sinvoll erschienen
und der Eintrag in der ARP-Tabelle des Routers korrekt eingetragen war,
jedoch keine Kommunikation mit dem 10/8 Netz moeglich war, und 
DHCP eingeschaltet. Mit eingeschaltetem DHCP gab der DHCPd eine 
Fehlermeldung beim start aus und man konnte sich nurnoch mit dem 
Rootaccount anmelden. Die routen hatten keine Namen mehr, allerdings
konnte sich tjener beim booten eine IP-Adresse holen und normal mit dem 
10/8 Netz und dem Internet kommunizieren. Dafuer fehlte dann dementsprechend
der Zugang zum LDAP. 

Es bestand zu jeder Zeit eine Route zum 10/8 Netz und ein ARP-Eintrag fuer
das Gateway/den Router. Dementsprechend vermute ich, dass ein im LDAP
gespeicherte Konfiguration die Kommunikation verhindert und wenn eine 
per DHCP bezogene Adresse verwendet wird, LDAP nicht erreicht werden kann
und so die die auf eth0 unterbindene Einstellung nicht geladen werden kann. 
Ich kann auch voellig falsch liegen, aber das waere eine fuer mich im 
Moment plausibel erscheinende Erklaerung. 

Ich hoffe ihr koennt mir bei meinem Problem helfen. 


Viele liebe Gruesse
Microvax



Reply to: