[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Skolelinux-Sarge: Risiko beim Nachinstallieren ?



Am Montag, 3. Oktober 2005 18:55 schrieb Martin Herweg:
> Hi Liste!
>
> In einer Schule habe Skoleninux(Sarge) laufen.
> Der Admin vor Ort wollte Bluefish oder Quanta+ nachinstallieren.
>
> Ich habe in
> /etc/apt/*
>
> "unstable"  gegen "stable" ausgetauscht, denn sarge ist ja jetzt stable.
> und
> apt-get update ausgefürt
>
> ich bekomme folgende Warnungen angezeigt:
>
> tjener:/etc/apt# apt-get install bluefish
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut... Fertig
> Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu
> korrigieren:
> Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
>   bluefish: Hängt ab: libart-2.0-2 (>= 2.3.16) soll aber nicht installiert
> werden
>             Hängt ab: libaspell15 (>= 0.60) soll aber nicht installiert
> werden Hängt ab: libatk1.0-0 (>= 1.7.2) soll aber nicht installiert werden
>             Hängt ab: libbonobo2-0 (>= 2.8.0) soll aber nicht installiert
> werden
>             Hängt ab: libbonoboui2-0 (>= 2.5.4) soll aber nicht installiert
> werden
>             Hängt ab: libc6 (>= 2.3.2.ds1-21) soll aber nicht installiert
> werden
>             Hängt ab: libgconf2-4 (>= 2.8.1) soll aber nicht installiert
> werden
>             Hängt ab: libglib2.0-0 (>= 2.6.0) soll aber nicht installiert
> werden
>             Hängt ab: libgnome2-0 (>= 2.8.0) soll aber nicht installiert
> werden
>             Hängt ab: libgnomecanvas2-0 (>= 2.6.0) soll aber nicht
> installiert werden
>             Hängt ab: libgnomeui-0 (>= 2.8.0) soll aber nicht installiert
> werden
>             Hängt ab: libgnomevfs2-0 (>= 2.8.3-7) soll aber nicht
> installiert werden
>             Hängt ab: libgtk2.0-0 (>= 2.6.0) soll aber nicht installiert
> werden
>             Hängt ab: libice6 soll aber nicht installiert werden oder
>                       xlibs (> 4.1.0) soll aber nicht installiert werden
>             Hängt ab: liborbit2 (>= 1:2.10.0) soll aber nicht installiert
> werden
>             Hängt ab: libpango1.0-0 (>= 1.8.1) soll aber nicht installiert
> werden
>             Hängt ab: libpcre3 (>= 4.5) soll aber nicht installiert werden
>             Hängt ab: libpopt0 (>= 1.7) soll aber nicht installiert werden
>             Hängt ab: libsm6 soll aber nicht installiert werden oder
>                       xlibs (> 4.1.0) soll aber nicht installiert werden
>             Hängt ab: libxml2 (>= 2.6.16) soll aber nicht installiert
> werden Hängt ab: zlib1g (>= 1:1.2.1) soll aber nicht installiert werden
> libdb1-compat: Hängt ab: libc6 (>= 2.2.5-13) soll aber nicht installiert
> werden
> E: Nichterfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne
> jeglich Pakete (oder geben Sie eine Lösung an).
>
> ============================================================
>
> tjener:/etc/apt# apt-get install quanta
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut... Fertig
> Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu
> korrigieren:
> Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
>   libdb1-compat: Hängt ab: libc6 (>= 2.2.5-13) soll aber nicht installiert
> werden
>   quanta: Hängt ab: kdelibs4 (>= 4:3.3.2-5) soll aber nicht installiert
> werden Hängt ab: libart-2.0-2 (>= 2.3.16) soll aber nicht installiert
> werden
>           Hängt ab: libc6 (>= 2.3.2.ds1-21) soll aber nicht installiert
> werden Hängt ab: libcvsservice0 (>= 4:3.3.0-0) soll aber nicht installiert
> werden
>           Hängt ab: libfam0c102 soll aber nicht installiert werden
>           Hängt ab: libgcc1 (>= 1:3.4.1-3) soll aber nicht installiert
> werden Hängt ab: libgcrypt11 soll aber nicht installiert werden Hängt ab:
> libgpg-error0 (>= 1.0) soll aber nicht installiert werden Hängt ab: libice6
> soll aber nicht installiert werden oder xlibs (> 4.1.0) soll aber nicht
> installiert werden Hängt ab: libidn11 (>= 0.5.13) soll aber nicht
> installiert werden Hängt ab: libjpeg62 soll aber nicht installiert werden
>           Hängt ab: libpcre3 (>= 4.5) soll aber nicht installiert werden
>           Hängt ab: libpng12-0 (>= 1.2.8rel) soll aber nicht installiert
> werden
>           Hängt ab: libqt3c102-mt (>= 3:3.3.4) soll aber nicht installiert
> werden
>           Hängt ab: libsm6 soll aber nicht installiert werden oder
>                     xlibs (> 4.1.0) soll aber nicht installiert werden
>           Hängt ab: libstdc++5 (>= 1:3.3.4-1) soll aber nicht installiert
> werden
>           Hängt ab: libx11-6 soll aber nicht installiert werden oder
>                     xlibs (> 4.1.0) soll aber nicht installiert werden
>           Hängt ab: libxext6 soll aber nicht installiert werden oder
>                     xlibs (> 4.1.0) soll aber nicht installiert werden
>           Hängt ab: libxml2 (>= 2.6.16) soll aber nicht installiert werden
>           Hängt ab: libxrender1 soll aber nicht installiert werden
>           Hängt ab: libxslt1.1 (>= 1.1.12) soll aber nicht installiert
> werden Hängt ab: zlib1g (>= 1:1.2.1) soll aber nicht installiert werden
> Hängt ab: kfilereplace soll aber nicht installiert werden Hängt ab:
> klinkstatus soll aber nicht installiert werden Hängt ab: kommander soll
> aber nicht installiert werden
>           Hängt ab: quanta-data (= 1:3.3.2-6) soll aber nicht installiert
> werden
>           Hängt ab: tidy soll aber nicht installiert werden
> E: Nichterfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne
> jeglich Pakete (oder geben Sie eine Lösung an).
>
>
> =====================================================
Also ich habs mal ausprobiert auf nem Skole-Server und es laesst sich 
einwandfrei installieren, zieht natuerlich einige Abhaengigkeiten mit sich.
libc6 ?
libstdc++5?
Hast du ein sauberes Sarge installiert, oder selbststaendig ein dist-upgrade 
gemacht?

>
> kann ich "apt-get -f install"
> wagen ?
> riskiere ich, dass danach wichtige Dinge nicht mehr funktionieren ?
>
>
> Danke & Gruß,
> Martin

Ja das kannst du, du kannst ja weiterhin sehen, was er tut und bevor er Pakete 
entfernt fragt er ja auch nach. Er versucht halt nur wieder einen "sauberen 
Zustand" herzustellen und die Abhaengigkeitsprobleme zu loesen (-f fix 
broken).
Falls du nicht zustimmst kannst du ja mit n antworten.

Greetings
Steffen

Attachment: pgpwFjwOiqKcl.pgp
Description: PGP signature


Reply to: