[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Pkg-utopia-maintainers] Bug#876070: libavahi-core7: Does not install



Hi!

On Mon, 2017-09-18 at 12:29:53 +0200, Michael Biebl wrote:
> Am 18.09.2017 um 09:02 schrieb Eric Valette:
> > Package: libavahi-core7
> > Version: 0.7-1
> > Severity: grave
> > Justification: renders package unusable

> > (Reading database ... 147923 files and directories currently installed.)
> > Preparing to unpack .../libavahi-core7_0.7-1_amd64.deb ...
> > Unpacking libavahi-core7:amd64 (0.7-1) over (0.6.32-2) ...
> > dpkg: error processing archive /var/cache/apt/archives/libavahi-core7_0.7-1_amd64.deb (--unpack):
> >  unable to install (supposed) new info file '/var/lib/dpkg/tmp.ci/shlibs': Structure needs cleaning

> I can't reproduce the problem. Neither on my laptop nor in a chroot test
> environment.
> 
> The shlibs file shipped by libavahi-core7_0.7-1 looks right to me
> (attached), so I have no idea what's going on here.
> 
> Guillem, can you chime in here, please. What does this error message
> mean and when and why can this happen.

Wow, I've never seen that errno message before. Quickly checking glibc
it seems this is coming from EUCLEAN, but glibc's manual is of no much
help. Checking linux seems like this indicates a filesystem corruption
error, at least on MTD, Lustre, BTRFS, crypto, extN, jbd, JFFS2, NFS,
UBIFS and XFS (based) "filesystems".

So this seems like a local error. Time for backups and fsck in case
the filesystem used does have such tool. :)

Thanks,
Guillem


Reply to: