[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg fails to install 32-bit adobe acrobat reader on 64-bit wheezy system: depends issue

Hey all,

I tried the debian-user list first with no luck so I'm checking with the experts.
This seems like some kind of bug in dpkg.

So this works fine on 64-bit squeeze:
> chiestand@squeeze:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb

But not on 64-bit wheezy:
> chiestand@wheezy:/tmp$ sudo dpkg -i --force-architecture adobereader-enu_9.5.1_i386.deb
> (Reading database ... 783153 files and directories currently installed.)
> Preparing to replace adobereader-enu 9.5.1 (using areader.old.deb) ...
> Unpacking replacement adobereader-enu ...
> dpkg: dependency problems prevent configuration of adobereader-enu:
> adobereader-enu depends on libgtk2.0-0 (>= 2.4).
> dpkg: error processing adobereader-enu (--install):
> dependency problems - leaving unconfigured
> Processing triggers for man-db ...
> Errors were encountered while processing:
> adobereader-enu

Notice the dependency failure. But the depend is actually satisfied in wheezy:
> chiestand@wheezy:/tmp$ dpkg -l libgtk2.0-0
> Desired=Unknown/Install/Remove/Purge/Hold
> | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> ||/ Name                        Version                     Description
> +++-===========================-===========================-======================================================================
> ii  libgtk2.0-0:amd64           2.24.10-1                   GTK+ graphical user interface library

Is this a multi-arch issue? I've tried setting up multi-arch:
> sudo dpkg --add-architecture i386
> sudo apt-get update

But I get the same result.

Any ideas, anyone?


Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply to: