[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted dpkg 1.16.2 (source all amd64)

Hash: SHA1

Format: 1.8
Date: Mon, 19 Mar 2012 07:27:12 +0100
Source: dpkg
Binary: libdpkg-dev dpkg dpkg-dev libdpkg-perl dselect
Architecture: source amd64 all
Version: 1.16.2
Distribution: unstable
Urgency: low
Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
Changed-By: Guillem Jover <guillem@debian.org>
 dpkg       - Debian package management system
 dpkg-dev   - Debian package development tools
 dselect    - Debian package management front-end
 libdpkg-dev - Debian package management static library
 libdpkg-perl - Dpkg perl modules
Closes: 192619 229357 367608 427945 595144 608884 627832 636238 642473 642608 642802 643746 643969 644370 646496 647915 648180 648217 649248 651481 651813 651993 652414 653575 654453 654626 655411 656496 657849 658126 658696 658854 661638 663004
 dpkg (1.16.2) unstable; urgency=low
   [ Guillem Jover ]
   * Move <config.h> and <compat.h> to the top of trigdeferred.l to properly
     use the configured features and compat code.
   * Honour --disable-nls when the system lacks obstack support, by updating
     the obstack compat module from gnulib.
   * Link the libdpkg unit tests with libcompat and libintl, so that systems
     needing them will compile correctly.
   * Check for the presence of the strnlen declaration and correctly provide
     the compat one in case the systems lacks it.
   * Do not assume existence of paths on the build system in the test suite.
   * Do not fail to link dselect on MacOS X when using --disable-nls.
   * Remove versioned coreutils Pre-Depends from dpkg due to the ancient
     md5sum transition. Reported by Bill Allombert <ballombe@debian.org>.
     Closes: #643746
   * Change dpkg-architecture to only compute the requested variables. This:
     - Fixes the bootstrapping problem, as the dpkg build system only needs
       the host architecture, for which dpkg itself is not required.
     - Reduces the amount of work performed, including loading and parsing
       unnecessary table files or calling either of gcc or dpkg programs.
   * Improve error message in dpkg-gencontrol and dpkg-gensymbols when
     debian/control does not have any package stanza. Closes: #642473
     Based on a patch by Kyle Willmon <kylewillmon@gmail.com>.
   * Add Pre-Depends on tar >= 1.23 (satisfied in stable) to dpkg due to it
     using the ‘--warning=no-timestamp’ option. Closes: #642802
   * Do not segfault on GNU/Linux when dpkg cannot retrieve the block size
     for the filesystem containing the info database. LP: #872734
   * Fix two memory leaks per tar entry in the tar extractor used on unpack.
   * Mark dpkg and dselect as Multi-Arch foreign.
     Reported by Steve Langasek <vorlon@debian.org>.
   * Mark dpkg-dev and libdpkg-perl as Multi-Arch foreign. Closes: #648217
     Thanks to Colin Watson <cjwatson@ubuntu.com>.
   * Add new deb-origin.5 man page. Closes: #608884
     Thanks to Matt Kraai <kraai@ftbfs.org>.
   * Return correct status on start-stop-daemon --status when using --pidfile.
   * Treat dpkg-deb compression level independently for each backend. This
     has the effect of changing the current behaviour for level 0 on all
     compressors except gzip.
   * Add new dpkg-deb -S option to specify the compression strategy. The only
     currently supported value is “extreme” for xz. Closes: #647915
   * Stop using brace expansion to install man pages by using dh_installman
     instead of dh_install, the former does not abort on empty glob expansion.
   * Do not use absolute paths for programs in perl and shell code.
   * Add missing ‘*’ in asprintf() and vasprintf() compat declarations.
   * Add support for virtual output binary:Summary and db:Status-Abbrev fields.
     Closes: #192619, #427945
   * Add support for virtual output source:Package and source:Version fields.
     Closes: #653575
   * Use a different temporary file per process on libcompat's vsnprintf()
     function to avoid race conditions from children after fork(3).
     Reported by Daniel Ruoso <daniel@ruoso.com>. Closes: #655411
   * Fix start-stop-daemon --exec and --name options on FreeBSD, NetBSD and
     OpenBSD by swapping the process matching implementations.
   * Fix start-stop-daemon --name option on GNU/Hurd to match the process name.
   * Document in more detail the implications of start-stop-daemon matching
     options. Closes: #367608
   * Improve and clarify dpkg-shlibdeps superfluous linking warning messages.
     Based on a patch by Peter Eisentraut <petere@debian.org>. Closes: #656496
   * Relax --merge-avail Packages file parser, to not fail on bogus versions.
   * When building only arch-indep binaries with «dpkg-buildpackage -A», name
     the .changes file using ‘all’ as architecture. Closes: #661638
   * Handle unknown architectures gracefully in dpkg-buildflags.
     Closes: #663004
   * Add missing --status-logger to dpkg --help output.
   * Do not print bogus errno string for invalid package names in dpkg
     --ignore-depends option.
   * Change dpkg-query to not load the available file by default for --list
     and --show, add a new --load-avail option to expose the old behaviour.
   * Only allow setting selections via «dpkg --set-selections» for known
     packages (i.e. those present in either the status or available files).
   * Always ignore older versions when parsing the available file, not only
     for --update-avail and --merge-avail.
   * Mark not-installed non-arch-qualified selections for removal.
   * Add new «dpkg --assert-multi-arch» command to allow checking for
     multi-arch support availability.
   * Bump Standards-Version to 3.9.3 (no changes needed).
   * Add architecture consistency checks to «dpkg --audit».
   * Add new dpkg --add-architecture and --remove-architecture commands to
     track supported architectures.
   [ Raphaël Hertzog ]
   * Update Dpkg::Shlibs to look into multiarch paths when cross-building
     too. Closes: #595144
   * Rewrite architecture.mk with explicit loops instead of duplicating many
     similar lines. Based on a patch by Thorsten Glaser <tg@mirbsd.de>.
   * Modify dpkg-gencontrol and dpkg-distaddfile to grab a write lock
     on debian/control before updating debian/files to avoid simultaneous
     updates. Closes: #642608
     Add libfile-fcntllock-perl to dpkg-dev's Depends since we use this module
     to handle the locking.
   * Update dpkg-gensymbols(1) to clarify that -e accepts shell patterns
     expansions and not regular expressions. And let dpkg-gensymbols output a
     warning when a pattern doesn't match any file. Closes: #649248
   * Add new option "-a <arch>" to dpkg-checkbuilddeps to check build
     dependencies for another architecture. This is really basic for now since
     it assumes all build dependencies must be satisfied on the listed
     architecture. Closes: #648180 Thanks to Colin Watson for the patch.
   * Error out if a dpkg database .list file is not a regular file. LP: #369898
   * Fix dpkg-mergechangelogs to not error out on invalid versions.
     Closes: #651993
   * Fix dpkg-source --commit on "3.0 (quilt)" when an explicit patch file
     is given with a relative filename. Closes: #652414
   * Further clarify in dpkg-source(1) the conditions under which it's possible
     to pass an explicit patch file to dpkg-source --commit.
   * Add new --query-features command to dpkg-buildflags. Thanks to Kees Cook
     for the patch. Closes: #651481
   * Fix description of Multi-Arch in deb-control(5). Closes: #654453
     Thanks to Jakub Wilk for spotting the mistake.
   * Drop misleading spaces in deb-symbols(5) in the format description.
   * Clean up dpkg-architecture(1) dropping useless information and
     adding a reference to /usr/share/dpkg/architecture.mk.
   * Update dpkg-buildpackage to use the "build-arch" (for -B) and
     "build-indep" (for -A) targets unless "make -qn" says that they do not
     exist. Closes: #229357
   * Improve deb-shlibs(5) to mention that the dependency field must
     use the same syntax than a Depends field. Closes: #658696
   * Update dpkg-maintscript-helper(1) to recommend usage of the version
     removing/renaming a conffile with a "~" suffix as "priorversion"
     parameter. Thanks to Sam Morris <sam@robots.org.uk> for the patch.
     Closes: #658854
   * Fix debug output of dpkg-maintscript-helper. LP: #936340
   [ Jonathan Nieder ]
   * Bump po4a version in Build-Depends to 0.41, since earlier versions do
     not handle --srcdir correctly. Closes: #644370
   [ Guillem Jover, Steve Langasek, Raphaël Hertzog ]
   * Add new dpkg --print-foreign-architectures command.
   * Add support for virtual output binary:Package field.
   * Implement Multi-Arch support.
   [ Helge Kreutzmann ]
   * Fix a typo in man/dpkg-deb.1.
   [ Updated dpkg translations ]
   * German (Sven Joachim).
   * Italian (Milo Casagrande). Closes: #627832, #657849
   * Swedish (Peter Krefting).
   * French (Christian Perrier)
   * Polish (Michał Kułach). Closes: #658126
   [ Updated scripts translations ]
   * German (Helge Kreutzmann).
   * Spanish (Omar Campagne). Closes: #636238
   * Swedish (Peter Krefting).
   [ Updated man page translations ]
   * German (Helge Kreutzmann), including typo fix in dpkg-genchanges
     Closes: #646496, sub optimal translation of package states LP: #368783
     and an fix by Chris Leick
   * Japanese (TAKAHASHI Motonobu).
   * Spanish (Omar Campagne). Closes: #643969
   * Swedish (Peter Krefting).
   * Minor errors corrected in French (thanks to David Prévot)
   * Fix translation of -B and -A options of dpkg-buildpackage.
     Thanks to Vincent Danjean. Closes: #654626
   [ Updated dselect translations ]
   * Dutch (Jeroen Schot). Closes: #651813
 77256a48ee15cf6c7b13fe54e005e392bf13e608 1362 dpkg_1.16.2.dsc
 43ea22771b0dd9eb5bf7ceaf672400e7196a2bea 5578978 dpkg_1.16.2.tar.bz2
 ca0ba8572881a940aad51a0d029560dacb6a2156 621048 libdpkg-dev_1.16.2_amd64.deb
 0b4298d541724b07fbf549249812971bf335fc42 2326938 dpkg_1.16.2_amd64.deb
 06164d70bb28998bde8db6790a2123048e6d62e0 1070312 dselect_1.16.2_amd64.deb
 db6b45db3dcbd7016bf43ab9ea5050844234591e 1165258 dpkg-dev_1.16.2_all.deb
 3c91d7a0f934cebeb90f6b1200785f3c142bc79c 860916 libdpkg-perl_1.16.2_all.deb
 16f885e5d1215c12c980b77e104bff41cc82f36431f91ed21990693324d87793 1362 dpkg_1.16.2.dsc
 53a77f694ce2269f17729b0e9626c59687683703e3822a2624b13da4a10fccc9 5578978 dpkg_1.16.2.tar.bz2
 37c676f894980da2a6bd074f2326722c8233e6bc4d507f0c8161d903193f6c38 621048 libdpkg-dev_1.16.2_amd64.deb
 f096294c2d0c6ea790137d3170fb692404d3f364363f56480f9688490945c508 2326938 dpkg_1.16.2_amd64.deb
 83973997ecc90a318accfc4ba45bd18c10a5d9c15a959b9403f3c890db61320d 1070312 dselect_1.16.2_amd64.deb
 541749e314b3d3228ce1b89666aefa4a26353d057b675e85da82a099a6684513 1165258 dpkg-dev_1.16.2_all.deb
 8864e6735ee12452435a859bd0444bed7364032e5118b91a0fbf1345a618bc44 860916 libdpkg-perl_1.16.2_all.deb
 4c0e64a5775c90db51d3cb0263b81852 1362 admin required dpkg_1.16.2.dsc
 629ba7ee2024e6a5c0ff807aa2db02f8 5578978 admin required dpkg_1.16.2.tar.bz2
 4e2d60c52c2b04787dbc8bee72e6044d 621048 libdevel optional libdpkg-dev_1.16.2_amd64.deb
 6dbfc23909173f7948b6d67cd5f478eb 2326938 admin required dpkg_1.16.2_amd64.deb
 d3e07e1f216935c7db59ced3e9950909 1070312 admin optional dselect_1.16.2_amd64.deb
 e3cc2a84e29ac98690ca150d37a557af 1165258 utils optional dpkg-dev_1.16.2_all.deb
 9f4869d928df7aad7f22295d9ab28215 860916 perl optional libdpkg-perl_1.16.2_all.deb

Version: GnuPG v1.4.12 (GNU/Linux)


  to main/d/dpkg/dpkg-dev_1.16.2_all.deb
  to main/d/dpkg/dpkg_1.16.2.dsc
  to main/d/dpkg/dpkg_1.16.2.tar.bz2
  to main/d/dpkg/dpkg_1.16.2_amd64.deb
  to main/d/dpkg/dselect_1.16.2_amd64.deb
  to main/d/dpkg/libdpkg-dev_1.16.2_amd64.deb
  to main/d/dpkg/libdpkg-perl_1.16.2_all.deb

Reply to: