Re: [PATCH v2 3/4] dpkg: change pass_admindir to a bool
Hi!
On Sat, 2009-10-24 at 18:40:14 -0500, Jonathan Nieder wrote:
> This is just for clarity. Noticed while preparing to add a
> similar pass_memlimit option.
> diff --git a/src/main.c b/src/main.c
> index 78c34c3..ff09fa0 100644
> --- a/src/main.c
> +++ b/src/main.c
> @@ -546,7 +546,7 @@ void execbackend(const char *const *argv) {
> int offset = 0; /* offset for copying argv strings to nargv */
> int argc = 1; /* for nargv */
> const char *const *arg = argv;
> - int pass_admindir = 0;
> + bool pass_admindir = false;
>
> while (*arg != NULL) {
> arg++; argc++;
> @@ -559,7 +559,7 @@ void execbackend(const char *const *argv) {
> if (strcmp(cipaction->parg, DPKGQUERY) == 0 &&
> strcmp(admindir, ADMINDIR) != 0) {
> argc++;
> - pass_admindir = 1;
> + pass_admindir = true;
I think I had this in my pu/c-bool branch, but it's not needed anymore
anyway with the new command support.
thanks,
guillem
Reply to: