[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: UNable to configure my package



On Wed, 26 Sep 2007 02:30:36 -0700 (PDT)
varun_shrivastava <varun.celunite@gmail.com> wrote:

> 
> thanks for the reply
> i want to add some information that i m using a cross compilation tool
> "scratchbox"

Then you should look at Emdebian which has updated tools for
cross-building using Debian sources.

http://www.emdebian.org/

(Next time, please mention that you are cross-building as the very
first thing you say because 99.999% of Debian people will try and
answer from a *native* build perspective - even those who regularly
cross-build a variety of packages, like me.)

> All the source code i have installed in scratchbox is using make install
> (not from the deb packages)

So why are you trying to install your program using dpkg?
dpkg: dependency problems prevent configuration of clock:
 clock depends on libgtk-directfb-2.0 (>= 2.2); however:
  Package libgtk-directfb-2.0 is not installed.

If you want to use dpkg to install clock, you must install
libgtk-directfb-2.0-0 using dpkg too, irrespective of whether you are
using scratchbox or emdebian-tools.

> So if i want to convert an application to deb package, first i need to
> convert all other source code  (becoz i have made changes to them according
> to my requirement) that i have installed using make install, otherwise i
> wouldn't be able to make a deb package.

But you cannot install that deb package without also installing the
dependency as a deb as well. If you install a dependency of a package
with 'sudo make install' then you must install the package with 'sudo
make install' as well - you cannot revert to dpkg without also
installing all dependencies via dpkg.

I'm an Emdebian developer as well as a DD so I am used to
cross-building Debian packages. However, I don't use scratchbox because
(unless you are using scratchbox2) there are known bugs and it's quite
out of date.

If you want to work with upstream source, use OpenEmbedded.

If you want to work with Debian packages, use Emdebian.

If you want help on using scratchbox2, ask on the debian-embedded
mailing list (where you'll find the scratchbox2 maintainer, me and
various other cross-building types).

Whatever you want, this problem is *not* in dpkg and there isn't any
point continuing this thread here.

-- 


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpO2lA_vXm6a.pgp
Description: PGP signature


Reply to: