[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#237245: install-info: breaks maintainer scripts at least of tar and xemacs21-support

Package: dpkg
Version: 1.10.19
Severity: grave
Justification: breaks installation of other packages, of which tar is essential

The install-info program seems to have changed its syntax
incompatibly. This morning, I got an error from tar's postinst, later
also from xemacs21-support's postinst and prerm. This is the error
message for tar:

Unpacking replacement tar ...
Setting up tar (1.13.93-2) ...
install-info: No such file or directory for General Commands
dpkg: error processing tar (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

xemacs21-support gives the same message in postinst, in prerm it is: 

Removing xemacs21-support ...
install-info: No dir file specified; try --help for more information.

The command line in tar's postinst is:

install-info --quiet --section "General Commands" "General Commands" \

Issued manuall by root, it gives the same error, even without
--quiet. It hasn't changed since woody, so I doubt the error is in
tar. Commenting out these lines helped (dpkg --configure -a was
successful after that), but that can't be a general solution.

Regards, Frank

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.25
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro

Versions of packages dpkg depends on:
ii  dselect                     1.10.19      a user tool to manage Debian packa
ii  libc6                       2.3.2.ds1-11 GNU C Library: Shared libraries an

-- no debconf information

-- System Information
Debian Release: 3.0-bunk-2
Architecture: i386
Kernel: Linux alhambra 2.4.25 #1 Mit Feb 18 16:41:07 CET 2004 i686
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro

Versions of packages dpkg depends on:
ii  libc6                  2.2.5-11.5        GNU C Library: Shared libraries an
ii  libncurses5            5.2.20020112a-7   Shared libraries for terminal hand
ii  libstdc++2.10-glibc2.2 1:2.95.4-11woody1 The GNU stdc++ library

Reply to: