[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: aptitude, install-info, gzip strange behaviour

Michal Politowski wrote:
> Configuring mtools resulted in broken pipe from gzip
> to install-info, which in itself is as far as I was able
> to read from install-info completely normal and happens all the time.
> This time it caused install-info to stop with
> gzip: stdout: Broken pipe
> install-info: read gzip -d </usr/share/info/mtools.info.gz |: 256

I saw this same install-info breakage when building a woody chroot with
debootstrap. I can probably reproduce it at will; at least I was able to
reproduce it once.

> not a sign that install-info knew anything about the SIGPIPE.
> But of course upgrading mtools without touching gnupg
> worked fine, running dpkg --configure -a from the shell worked as well.
> Should it be reported as a bug in aptitude? I'm very unsure about that.
> PS. I'm not on debian-devel yet, so please cc me if possible.

I think it's a bug of some kind in install-info, ccing to the dpkg list.

see shy jo

Reply to: