[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP... ldso?

Dear David,

Thanks for the reply.
I had tried to run dpkg after dselect failed, but I got
the same messages. I don't know what caused the problem: the first
unusual thing I saw was that dselect explicitly complained about
unsatisfied predependency ldso, and upgraded ldso before anything
else. And then continued with the rest, but all other packages
failed with the messages about post-removal script.

However, I incidentally found out what had happened: during the
upgrade procedure done inside dselect, the link /bin/sh pointing to
/bin/bash disappeared. When I manually made the link, I could
use dpkg to upgrade ldso, libc6 and bash. Then I used dselect
for the rest and my system finally came back to life!

So those messages about "no such file or directory" probably refered
to /bin/sh not being found. But many things during the first dselect
procedure could have caused the link /bin/sh to have disappeared:
it could have been dselect, dpkg, the install scripts for bash,
for libc6, etc. Because ldso was the first thing to be upgraded,
I sent you the message. And I was also totally stuck, the man
pages did not respond, and I had tried all "--force" options
in dpkg without success... 

It would be interesting to figure out what caused the link /bin/sh
to disappear, since that was what caused the failure of the whole
upgrade procedure, leaving the system in a weak condition.


> On Mon, Sep 20, 1999 at 01:45:21PM -0300, Marcia Takagui wrote:
> > After this, dselect continued BUT... I started to get messages like:
> > 
> > dpkg (subprocess): unable to execute old post-removal script: No such file or directory
> > dpkg: warning - old post-removal script returned error exit status 2
> > dpkg - trying script from the new package instead ...
> > dpkg (subprocess): unable to execute new post-removal script: No such file or directory
> This is strange.  ldso doesn't have a postrm script.  Are you sure the
> message is for the ldso package?
> > dpkg: error while cleaning up:
> >  subprocess post-installation script returned error exit status 2
> > 
> > And now many important packages are broken or half-installed,
> > including libc6, which was one of the packages dselect marked to upgrade.
> > And I can do nothing! 
> > 
> > BACK?? The man pages for many important programs also disappeared...
> Since I don't know what state your system is in, I don't really know
> what you need to do.  Have you tried running dpkg directly to install
> some of the more critical package such as ldso and libc6?
> David
> -- 
> David Engel
> dlengel@home.com

% MARCIA TAKAGUI                     E-MAIL: takagui@wslip1.if.usp.br
% Univ Sao Paulo - Fisica - DFGE     PHONE: (55) (11) 818-6811
% PO Box 66318, Sao Paulo, SP        FAX:   (55) (11) 813-4334
% 05315-970 BRAZIL                   <== new zip code since Oct 22 96

Reply to: