[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#33618: multiple* packagess insist on dpkg upgrade

Ian Jackson <ian@davenant.greenend.org.uk> writes:

> Andy Mortimer writes ("Re: Bug#33618: multiple* packagess insist on dpkg upgrade"):
> > Ian Jackson <ian@davenant.greenend.org.uk> writes:
> ...
> > > I notice that the
> > >  --assert-working-epoch
> > > option was added in the NMU series, but not filed as a bug, so it
> > > wasn't in my tree.
> > > 
> > > I've added it now (I've already fixed, I think, the bug that it refers
> > > to).
> > 
> > Just checking: you mean you've added/will add the option to the
> > version of dpkg in Hamm, so I can close this bug?  Otherwise, I can
> > reassign it to dpkg, or whatever you think best! ;-)
> No, I'm not going to add it to the dpkg in hamm because hamm does not
> exist any more.  

It exists until the last person upgrades it ... ;-)

> You're confused, I think.
> I'm referring to current dpkg development.

Erm ... perhaps I am.  I was thinking of bugs #33619/#33626, from
(IIRC) the same submittor, who was talking about the problems with
--assert-working-epoch in the *Hamm* version of dpkg making it
impossible for people to upgrade svgalib; this seems to be the same
bug as 33618, although I don't have the logs handy.  I therefore read
your statement as saying that you were going to fix the version in
Hamm; I'm not on top of things enough to know if there's a
"hamm-updates" lying around somewhere!

So long as the most recent versions of dpkg support this option
correctly, I guess there isn't a problem after all!  (Anyone upgrading
to the Potato svgalib should have recent dpkg, or they won't get very
far anyway).



Andy Mortimer                                 andy.mortimer@zetnet.co.uk
Andy walking, Andy tired,
Andy take a little snooze
    -- "Andy Warhol," David Bowie

Reply to: