[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compiling dpkg on a non-debian system


> > aclocal: configure.in: 93: macro `AM_GNU_GETTEXT' not found in library
> > aclocal: configure.in: 112: macro `AM_PROG_LIBTOOL' not found in library
> You need to install libtool and gettext.  Or just libtool and
> configure with --disable-nls.

First of all thanks to all who replied. Finally, I've managed to compile
dpkg on my system, but it wasn't that easy... (BTW, I'm running Linux on
an intel system, so acutal _porting_ issues did not show up in my case.)

I'll try to summarize what measures had to be taken in order to get
dpkg- to compile. Maybe someone will find the information
useful. (Especially when it comes to upgrading automake and friends...)

The system I was using was acutally lacking "libtool", but gettext-0.10
was already installed. The problem with "AM_GNU_GETTEXT" was solved by
upgrading to gettext 0.10.35 as it can be found on alpha.gnu.org.

Furthermore, I had to upgrade autoconf from version 0.12 to 0.13 in order
to get rid of "@SHELL@: command not found" messages emitted by automake
version 1.4.

Next, I ran into problems with automake about "CXX being not defined in
configure.in" when it was processing the dselect directory. I got around
that problem by applying the following patch to configure.in:

--- configure.in.orig	Fri Mar  5 14:58:35 1999
+++ configure.in	Fri Mar  5 13:59:30 1999
@@ -11,7 +11,7 @@
 tl_CHECK_TOOL(LD, ld, ld)

Unfortunately, the standard "config.sub" file that is used for building
dpkg in the "debian/rules" file did not work any more for me. Patching
debian/rules did the trick for me:

--- rules.orig	Fri Mar  5 15:01:31 1999
+++ rules	Fri Mar  5 15:01:48 1999
@@ -19,8 +19,6 @@
 	gettextize --force
 	libtoolize --automake --copy --force
-	$(RM) config.sub config.guess 
-	ln -s /usr/share/automake/config.sub .
 	automake --add-missing
 $(BUILD)/Makefile: Makefile.in

After that changes, dpkg basically built for me. Hickups further arose
from not having "debiandoc2html" on my system. I also had to straighten
out a few minor problems with egcs-1.0.3 that we (still) use for compiling
plain C, too, when it came to host/target system detection.

Also, a little egcs-1.0.3 bug showed up when compiling "localealias.c"
which is part of gettext-0.10.35...

I hope that this information will be helpful for other people who want to
give dpkg a try on a non-debian system...


\       DI. Christian Czezatke  | email: czezatke@xss.co.at       /    
 \      xS+S Andreas Haumer     | phone: +43-1-6001508           /
  \     Karmarschgasse 51/2/20  | fax:   +43-1-6001507          /
   \    A-1100 Vienna/Austria   |                              /

Reply to: