[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#31521: dpkg: dpkg dies when run in an Eterm

Package: dpkg

  When dpkg --install is run in an Eterm, some packages fail to install with
the following error (dnsutils in this case):

(Reading database ... 45426 files and directories currently installed.)
Preparing to replace dnsutils 1:8.1.2-5 (using .../archives/dnsutils_8.1.2-5.deb) ...
Leaving `diversion of /usr/bin/addr to /usr/bin/addr.bind by dnsutils'
Unpacking replacement dnsutils ...

gzip: stdout: Broken pipe
dpkg-deb: subprocess gzip -dc returned error exit status 1
dpkg: error processing /var/cache/apt/archives/dnsutils_8.1.2-5.deb (--install):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
Errors were encountered while processing:
Exit 1

  This occurs when dpkg is invoked manually or by apt; running it in another
terminal (xterm or the linux console) solves the problem.

-- System Information
Debian Release: 2.1
Kernel Version: Linux palantir 2.0.36 #1 Tue Jan 5 13:09:23 EST 1999 i686 unknown

Versions of the packages dpkg depends on:
ii  libc6           2.0.7v-1       The GNU C library version 2 (run-time files)
ii  libncurses4     4.2-3          Shared libraries for terminal handling
ii  libstdc++2.9    2.91.60-2      The GNU stdc++ library (egcs version)

Reply to: