[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#26084: more on: dpkg: core dumps while installing apache-ssl)


I have had the same error 
(a core dump from  dpkg  with a strange error message)
over and over again;
 I use the apt-get (from slink) method for dselect
 so I cannot properly tell if it was always happening
 when apt-get tried to to "dpkg --configure apache-ssl"
 (apt-get lacks badly an option like  -d  or  -v 
 to have some verbosity/debug info)
I have eventually removed  apache-ssl
and   dpkg   was again working ok

today I retried :

root:Tonelli:/tmp :-)apt-get install apache-ssl
Updating package status cache...done
Checking system integrity...ok
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 523k of archives. After unpacking 1199k will be used.
Get http://non-us.debian.org stable/non-US apache-ssl [523k]
Fetched 523k in 11s (46.1k/s)               
Selecting previously deselected package apache-ssl.
(Reading database ... 24014 files and directories currently installed.)
Unpacking apache-ssl (from apache-ssl_1.2.6+1.16-3.deb) ...
dpkg: ../../../dpkg/packages.c:191: process_queue: Assertion dependtry <=4' failed.
E: Sub-process returned an error code

(this time, no core dump)

so the problem is exactly in dpkg  trying to install apache-ssl



Reply to: