[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: https://manpages.debian.org/ - PARTIAL breakage

(Note: copying debian-doc as this is where we discuss any issues with
the manpages service)

On 23 February 2017 at 16:36, Richard Owlett <rowlett@cloud85.net> wrote:
> I just went to https://manpages.debian.org/ and entered chroot in the search
> box.
> It sent me to
> https://manpages.debian.org/jessie/manpages-es-extra/chroot.1.es.html .

The redirector tries to find the "best" manpage and forwards you to
that one. Unfortunatley, this seems to be a bug in the
manpages-es-extra manpage, which provides a chroot manpage in section
1 (instead of section 8, where it should be), and confuses the

Anyway,  if you want to see the English manpage in section 8 you can
access it by going to: https://manpages.debian.org/8/chroot

> https://manpages.debian.org/jessie/debootstrap/debootstrap.8.en.html .
> Following the structural example of that URL I attempted to go to
> https://manpages.debian.org/jessie/chroot/chroot.8.en.html .
> That sent me to
> https://dyn.manpages.debian.org/jessie/chroot/chroot.8.en.html?

The actual URL you should have used is

The URL structure is
/<distribution_name>/<package_name>/<manual_page>. In the URI you
tried, the service tried to look for a chroot manpage in the chroot
package. But there is no chroot package (it is coreutils), thus the
error you received.

Best regards


Reply to: