[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#513627: prepariing for the upgrade section should mention kernel versions.

package: release-notes

lenny's libc6 will fail preinst on kernels older than 2.6.8 (Afaict this applies to all architectures except m68k but I could be misreading the script) and on some architectures will fail on higher than that. Depending on the order in which the package manager decides to take action this can leave the dependencies in rather a mess. Recovery from this situation often involves removing a lot of packages to get the dependency state sane and allow the installation of an etch kernel.

While there already is a mention that 2.4 users should upgrade thier kernel first there are two issues with this warning
1: the user may be using an early 2.6 kernel
2: the section is in the wrong place, this is an issue that needs to be sorted out before starting the upgrade to lenny yet it's mentioned in the middle of the upgrade process.

IMO the preparing for the upgrade section should contain something along the lines of

Make sure you are on a suitable kernel
Lenny's version of glibc will not work with kernels older than 2.6.8 on any architecture and some architectures have higher requirements. We strongly reccomend that you upgrade to and test an etch 2.6.18 or 2.6.24 kernel or a custom kernel of at least version 2.6.18 before beggining the upgrade process.

Reply to: