[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#499093: Document MODULES=dep requirement for lilo

On Sat, Oct 04, 2008 at 09:30:35PM +0200, Luk Claes wrote:
> Hi Wouter
> Can you please provide a proposed text (license: GPL v2) regarding this
> requirement for inclusion in the release notes?

The following would work, and should probably be put in the section that
documents steps to be taken before starting the upgrade:

  Users using the LILO bootloader should note that the default settings
  for initramfs-tools now generate an initramfs that is too large for
  LILO to load. Such users should either switch to grub, or edit the
  file /etc/initramfs-tools/initramfs.conf, changing the line
  to read
  Note, however, that doing this will cause initramfs-tools to install
  only those modules that are required for the particular hardware that
  it is run on, onto the initramfs; as such, if you want to generate a
  boot medium that will work on more hardware than just the one you're
  generating it on, you should leave the setting to MODULES=most and
  make sure you do not use LILO.

<Lo-lan-do> Home is where you have to wash the dishes.
  -- #debian-devel, Freenode, 2004-09-22

Reply to: