[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#499093: Document MODULES=dep requirement for lilo

Package: release-notes
Severity: normal


The default setting for initramfs is MODULES=most, meaning that it will
try to install a lot of modules that aren't necessary for the system
you're running on.

With the kernel in lenny, on at least amd64 (I didn't try i386), this
results in an initramfs image that is too large for lilo to load. As a
result, this renders the system unbootable.

It should be documented that users who wish to keep using lilo should
use MODULES=dep, and the effect of this setting (that it loads only
those modules that are required for the system mkinitramfs is running

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.26-1-powerpc
Locale: LANG=nl_BE.UTF-8, LC_CTYPE=nl_BE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: